Please UPDATE to 1.2.6 NRS - Older Versions can caues Network Issues!