Problem with jminer


  • Banned

    I have been getting thiss error and jminer just freezes there:
    unable to get mining info from wallet: for input string:1844487444871715484321"

    I did put a walletserver in the jminer.properties but still the same problem, any ideas how to fix it?

    0_1471002307159_jminer.jpg


  • admin

    Please post your jminer.properties, never saw such error before ...


  • Banned

    plotPaths=Y:/Burst/plots,X:/Burst/plots,W:/Burst/plots,V:/Burst/plots,U:/Burst/plots,T:/Burst/plots,S:/Burst/plots,C:/Burst/plots,
    poolMining=true
    numericAccountId=5784742401147522465
    poolServer=http://pool.burstmining.club
    walletServer=http://localhost:8125
    winnerRetriesOnAsync=
    winnerRetryIntervalInMs=
    devPool=
    devPoolCommitsPerRound=
    soloServer=http://localhost:8125
    passPhrase=xxxxxxxxxxxxxx
    targetDeadline=
    platformId=0
    deviceId=0
    restartInterval=240
    chunkPartNonces=320000
    refreshInterval=2000
    connectionTimeout=6000


  • admin

    there is a ',' (comma) at the end of plotPaths try remove that.

    if that does not work, please add:

    listPlotFiles=true

    to jminer.properties and make a screen, i do not understand were this '1844487444871715484321' comes from.



  • @luxe plotPaths=H:/Burst/plots,G:/Burst/plots,E:/Burst/plots,

    was my plot files when I used jminer so the comma is correct. I also went to appdata to see what the AIO wallet wrote for the config statement it also had a comma.


  • admin

    @tross ok, well that was the only thing looks 'wrong' for me in properties^^


  • Banned

    I tried removing the comma and adding the listplotfiles-true and yet the same result happens.

    '1844487444871715484321' is one of my plots, example:

    Windows Burstcoin plot generator V1.17 by Cerr Janror

    Please consider donating some of your newly mined Bursts to support further development:
    BURST-LNVN-5M4L-S9KP-H5AAC

    Creating plots for nonces 18446744071922212865 to 18446744071929837569 (1861 GB) using 2176 MB memory and 4 threads - using SSE4 codepath...
    Setting priority class 'below normal'...
    Allocating memory...
    Checking directory...
    Opening file...
    Checking file size...
    Choosing worker routine...
    0 Percent calculated. writing data...



  • @Focus walletServer=http://localhost:8125 leave this blank only walletServer=


  • Banned

    @tross it was blank before, haitch suggested I try defining a wallet, again same problem


  • admin

    Ok, than we got the problem ... jminer can not handle nonce numbers higher than Long.MAX_VALUE -> 9223372036854775807

    walletServer is ok


  • Banned

    @luxe, excuse my ignorance, what would be the solution then?


  • admin

    how many plotfiles do you have plotted ending (2nd number+3rdnumer) higher than 9223372036854775807
    however, you can not use this plotfiles with jminer

    the nonces address range is enogh for petabytes, so i never saw a real issue there,
    and never fixed https://github.com/de-luxe/burstcoin-jminer/issues/2


  • Banned

    I have:
    1 x 1TB
    4 X 2TB
    1 x 5TB

    So 6 plots over that size


  • admin

    so you used another miner before? you may contain using that one or replot the not supported files.
    first maybe try removing the drives with that not supported plotfiles, and look if jminer works than.


  • Banned

    I know jminer works without those plots. It's just a lot of work and time replotting all those plots, I don't have that good GPUs so I use CPU plotting.

    I really would like to use GPU mining cause it is faster...


  • admin

    yes, sorry for that ... i see the pain ... but there is no chance to fix the plotfiles for jminer.
    maybe try running 2 miners, one for not supported plots on CPU and rest on jminer?!


  • Banned

    And no way to fix jminer using biginteger?



  • @Focus did you try to mine those plots with cpu miner to see what happens


  • Banned

    No problem using cpuminer but extremely slow, sometimes my plots are not fully checked and a new block arrives



  • @Focus thats strange cause I never had an issue where cpu worked and gpu not.