gpuPlotGenerator keeps erroring out



  • Hey guys! I am back from about a nearly 2 year Burst hiatus, but I am ready to gear up and start again. I have about 80TB I am getting ready to plot. Right now, I am trying to plot using the latest version of the gpuPlotGenerator. I have a couple different cards/computers I am trying with...one PC with a R9 270x (AMD 6-core, 16GB RAM) and the other with 2x R9 280x (i7-2600k, 32GB RAM). I have tried several different times but the plotting keeps erroring out after awhile. Sometimes right away, sometimes it runs for 8 hours before it errors out.

    Here is the script I am running on the machine with the 280x and 10 external 5TB HDs hooked up -
    C:\Users\dr\Desktop\gpuPlotGenerator-bin-win-x64-4.0.2\gpuPlotGenerator.exe generate buffer I:/Burst/Plots/13145299380788911090_100000000_19000000_8192 J:/Burst/Plots/13145299380788911090_119000000_19000000_8192 K:/Burst/Plots/13145299380788911090_138000000_19000000_8192 L:/Burst/Plots/13145299380788911090_157000000_19000000_8192
    pause

    ..and my Devices file -
    0 0 4224 192 8192
    0 1 4224 192 8192

    Any idea what could be causing this? Of course I have tried just plotting one at a time as well. The other machine gives the same general error after awhile as well. Does the gpuPlotGenerator pick up where it left off or do I need to delete incomplete plots and restart? That is what I have been doing so far.

    Any help would be greatly appreciated!



  • @DrTrouble
    Are you using the GPUs to run your monitor? If so, either move your monitor to integrated graphics while plotting or removed the GPU controlling the monitor from the device file.

    Another solution would be reducing the hash number. It might take longer, but the chance of crashing is smaller. You use a smaller number instead of 8192. (I'm using 16, but I got another type of GPU)
    Edit: More information about the last part: https://github.com/bhamon/gpuPlotGenerator/blob/master/README.md#setup



  • @FrilledShark
    Yes, one of the GPUs is hooked up to a single monitor. I am remote right now so I removed one of them from my devices file, although I am unsure of which one is actually driving my monitor. If this doesn't work, I'll try removing the other device. If neither of those works, I will reduce the hash number. If it takes longer that isn't a big deal, I just need to get these babies plotted! Thanks for the input.