Error reading file

  • Hello All, Can anyone help me with the following?

    I have 3 USB HDD connected to my laptop, and they are plotted correctly.

    Minert start without error, however, after few hours in the console there are many messages like "Error reading file"

    If I close the console and reopen/start the miner again, there is no issue for few hours then it appear again.

    Does anyone know why this is happening?

    The drives are error free without any bad sector.


  • @Blago : Thank you for the quick response.

    My system is already set to not go to sleep mode.

    Anyhow, I have set the power settings of the USB root and will test it if it makes any differences.

  • Still the same issue. Here is a screenshot of the console.

    Again, when I restart the miner all ok for a while.

    alt text

  • @Jumper @Blago I have this issue to with some of my google clouds, i thought this happened when all the clouds are completely filled, but latelly i made new clouds completely filled and this doesn't happen, i think is because on the first ones i had more than one plot in each drive and in the new ones besides i made the exact number of nonces that i want i leaved some nonces unplotted (i mean not too much xD)... I notice too that or the miner or the google drive creates a file with the space information and this file is hidden... Could be because of this file created if this is created by the miner, @Blago ?

    @Jumper this could be happening if you have the complete drive filled, i mean until the last nonce xD

  • @gpedro : Thanks. Well, I am not using google drive but by own USB drive. On my C drive which is an SSD drive, I have two plot file. an dthere is also plenty of space left on the drive.

    D drive is a 500GB usb HDD, with 1 plot file in it and there is about 4GB space left on it
    E drive is a 1.5 TB drive with 1 plot file on it, and there is about 7GB space free

    All plots are created with the app, burst client for windows.

    I have however noticed that if I start default miner, it is ok for longer time, but when I start the AVX miner,, error shows up really fast.

    So since I am 100% sure that my drives are error free, and by seeing teh default miner working better that the Recommended AVX, I guess the issue is with the miner.

  • @Jumper Well i know you are using physical HDD's i just reported what happened with me, if you have space available i don't have any cue xD Maybe it's real something that could be maked better in the next miner release...

  • @gpedro miner can't create any files at drive (only logs, if "UseLog" : true).

    once i had the same errors when i had external USB2 drive. It caused by losing connection to USB - windows made my drive to sleep mode.
    Now I have USB3 external drives - works fine.

  • @gpedro : Yeap, since my last post, miner working ok, the default one. On another system I tested the AVX miner and it come up with same error.

    I hope someone can fix this, however I will use the default one regardless the message in miner which advise me to run AVX version.

  • @Jumper your CPU type? (or name of laptop)

  • @Blago : Dell Latitude E6230, i7 CPU with 16GB RAM

  • @Blago :

    That might be the issue.

    I have now performed the following so will check if issue persist:

    (Found these steps online)

    1. Scroll to the right and type 'Power Options' in the search field and click on it.
    2. Click 'Change plan setting' on your chosen plan.
    3. Click 'Change advanced power setting' on your chosen plan.
    4. Find 'USB settings' and open.
    5. Find 'USB selective suspend setting' and change it to disabled.

  • @Blago So probably is some connection error to google in my case, and has nothing to do with the space on the clouds, this is very possible since NetDrive has released a lot of improvements with their updates, maybe i thought it was some issue with the filled drives but it can be that the new drives don't gave any error because of NetDrive improvements xD

  • For me is still the same issue. And I am sure is not USB issue since I am getting error for the C drive as well which is the system drive with a small plot file on it. Is there a way to debug this to see what causing this error?

  • Check the power settings and ensure your hard drives are not set to sleep after X minutes. If its happening on local C drive too this could be the reason.

  • @RiskyFire : Thanks. I did checked all power setting including the advanced one, so nothing should go to sleep mode. Not even the screen.

    I am also testing another miner (burst-miner-r4-win64) to see if there is any differences.

  • admin

    Could be the cable or the HDD itself.

  • check the health of your Hard drive. Use HDTune or whatever HDD checker you have.

  • @RiskyFire : Thank you man, you are the best. That was the issue. I had to click on the advanced settings and there was an option to spin down the drives after 20 min. So I disabled all options to sleep/spin down .... and issue fixed.

    For everyone who having similar issue:

    1: Open Power Options
    2: Switch to High Performance then Change plan settings
    3: Click Change Advanced power settings
    4: Disable all options under USB , SLEEP and Hard Disk

    Thanks again.

  • Well, after more that 12 hours, issue is back. Does anyone know how to debug this? So to see what exactly cannot be read to have a kind of more specific error message?

    I will try to use Linux box to see if that makes any better.

    If not, then I guess Burst mining is over for me as I do not see the point in investing time and money (HDD) if I cannot debug the issue 😞