Inconsistent Error Message-Ubuntu System



  • I am trying to plot a 5TB drive in Ubuntu 14.04 by following 'MDCCT Plotter/Optimizer/Miner 64bit' by Kartojal 2015 documentation. Downloaded and unzipped software. In plotter dir documentation suggests in Terminal to enter parameter '.gpuPlotGenerator listPlatforms' to obtain platforms # and id. When entered-Getting error:
    "Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion `needed != ((void *)0)' failed!'

    Have looked up information but I don't understand explanations. Can anyone help with this situation?
    Thanks for any help with this problem.


  • admin

    @vadirthedark I don't work in linux, but my best educated guess would be that it's not recognizing your GPU, driver issue ?



  • @vadirthedark
    I think that's an openGL error.
    Have you install the relevant SDK for your GPU?

    Also I could be completely wrong, and it could be a cmake error.

    I had so many bugs trying to plot with linux that I just mounted the drive as a samba share, mapped it to my windows PC as a drive then plotted from windows.
    -- Not the correct answer, but maybe it will help you?



  • @altcryptomining what bugs you encountered?



  • haitch,
    Have found this info for drivers:

    [email protected]:~$ lspci|grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
    [email protected]:~$ glxinfo | grep OpenGL
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce GTX 750 Ti/PCIe/SSE2
    OpenGL core profile version string: 4.3.0 NVIDIA 352.79
    OpenGL core profile shading language version string: 4.30 NVIDIA via Cg compiler
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 4.5.0 NVIDIA 352.79
    OpenGL shading language version string: 4.50 NVIDIA
    OpenGL context flags: (none)
    OpenGL profile mask: (none)
    OpenGL extensions:

    From System Settings → Details → Overview:
    Graphics GeForce GTX 750 Ti/PCIe/SSE2

    From System Settings → Software & Updates → Additional Drivers:
    NVIDIA Corporation:Unknown
    This device is using an alternative driver.
    Using NVIDIA Binary Driver-version 352.79 from nvidia-352 (open source)
    No proprietary drivers are in use.

    Does this mean that the system is seeing my graphics card but I am using a driver not meant for it?
    Thanks for your help, will research further.


  • admin

    @vadirthedark It's seeing your card, and has an openGL driver associated with it. Hopefully someone more familiar with plotting/mining on Linux can help.



  • You need the openCL SDK from NVIDIA

    https://developer.nvidia.com/opencl



  • haitch,
    You suggested: "you'll need to edit the Makefile file to change the values. Try nano Makefile ..." in 'Burst Software' in this forum. I used nano Makefile and get this:

    OPENCL_INCLUDE=/opt/AMDAPPSDK-2.9-1/include
    OPENCL_LIB=/opt/AMDAPPSDK-2.9-1/lib/x86_64

    -lglut -lGLU -lGL -lm -lpthread

    #include <lpthread.h>
    void junk() {
    int i;
    i=lpthread_getconcurrency();
    };

    However, these lines were added by me. The first time I looked at the 'Makefile' it was empty. I added the 'OPENGL_...' lines from documentation and the others via Internet research suggestion. The main question for me was that he original file was empty?? I looked for info on the './gpuPlotGenerator ...' and found a 'Makefile' on gethub.com with 65 lines-here are the first lines:

    OBJ_PATH = obj
    BIN_PATH = bin
    DIST_PATH = dist
    EXE_NAME = gpuPlotGenerator.exe
    PLATFORM = 32
    OPENCL_INCLUDE = ../_opencl/include
    OPENCL_LIB = ../_opencl/lib/win/x86

    Burst documentation suggests revising the last 3 lines for my purposes. To get to my question-what should a 'Makefile' look like?
    Any thoughts? Thanks for all your help.



  • Update - I was able to uninstall 'Using NVIDIA Binary Driver-version 352.79 from nvidia-352 (open source)' and install 'Using NVIDIA Binary Driver-version 340.98 from nvidia-340 (open source). In terminal re-ran './gpuPlotGenerator ...' and did not get any errors. I did not get a 'Platforms ID #'' as expected and required for input into 'devices.txt'.
    Still interested in 'Makefile' question above. On to next problem. 🙂