Plot Optimizer not working - help please

  • Nope... I just tried it again and turned monitor brightness and contrast up to 100% and i could not see any message there.

  • @GabryRox OK was worth a look as when I had a problem there was a difficult to read error message. You look to have entered all the fields correctly, so only other thing I can suggest is to not use the GUI but to edit the run.bat file for your plots and run the optimiser from that. You will need to look at the readme for how to set up.


  • @GabryRox I have issues with the GUI also, you can run it manually from the command line.. Follow these steps and it should work for you. (1).Open a command window. (2) Go to the folder with the optmizier.exe. (3) type the following command and press enter: Optimizer.exe <full path and folder where you want the optimized plot to be located> -m 8G <full path and filename of the plot file to be optmizied>

  • Thanks to both of you for your suggestions. I am still learning about command windows and such so wanted to make sure I have this right before attempting.

    1- to get to the folder (on my desktop) where the .exe is located, I use CD\ followed by the path, correct?

    2- as for the paths designated in the command line you mention, I just need the drive letter and not the name of the drive, correct?

    So, it would be something like this?

    Optimizer.exe F:\Burst\plots -m 8G E:\Burst\plots\11985852821262972615_800000001_4103424_8768

  • also... what is the recommendation for doing the optimizing concurrently while the miner is running (mining the same plot being optimized)? Will this cause a conflict? Just wondering if I should stop the miner during this process or not.

  • @GabryRox Looks good to me. As I said you can also put the command line into a bat file and then run the file. Useful if you make a mistake or can be easily edited for another plot. Also you can put in multiple lines with different plots and they will be executed in sequence.


  • @GabryRox You can mine while optimising. If you do not put the optimised drive letter in the mining plot path you will not submit the same Deadline twice. After it finishes replace the un-optimised drive letter with the optimised one.


  • @GabryRox It wont cause a conflict, but it will slow down the mining of the drive being optimized. Also to open a command window in the folder where the optmizer is located, find it in windows explorer then shift-right-click , one of the menu options will be "open a command window here".

  • More thanks to both... so, I just tried it and THINK it might be working. Firstly, I tried running that command line from the C:\desktop location i had it saved to but i wouldn't work. However, I then made a copy on my F drive and then ran the command line from that directory/folder and it appears to have started.

    It now says it is using the 8GB of memory to process 32 scoops at once. It said "processing" 1 of 4096 scoops for about 8 minutes, then came up with "processing 33"... So, while it seems that it is working, I am confused about something. While the command window is indeed showing the new file name, I cannot find it in the destination folder that I designated or anywhere else. Should I be concerned with this? I thought that it would begin to write that file right away. Is it possibly keeping it in RAM until the 8GB is full THEN write it to disk?

  • @GabryRox it is working, the new file will appear in time just do a refresh in explorer to show it.

  • @GabryRox said in Plot Optimizer not working - help please:

    1- to get to the folder (on my desktop) where the .exe is located, I use CD\ followed by the path, correct?

    Here is something very useful that will save you time navigating: Hold the shift key and then right click in an empty space in the folder you want to navigate to. You will now see an option that is only visible when you shift+right click, namely 'Open command window here'. Select it, and game's on ;)

  • using the command line aka. "cmd" is indeed much nicer! me thinks! (but keep in mind I'm a newb!-)
    Parameters are explained in the README.txt in your extracted optimizer folder.
    You can even do a "Batch processing file" aka. ".bat" file.

    An example would be something like this:

    mkdir N:\plots
    start /wait Optimizer.exe 30 N:\plots -del 1 D:\plots\10718900860795585473_807630672_3815336_77864
    start /wait Optimizer.exe 30 N:\plots -del 1 D:\plots\10718900860795585473_811446008_3815336_77864
    start /wait Optimizer.exe 30 N:\plots -del 1 D:\plots\10718900860795585473_815261344_3815336_77864
    start /wait Optimizer.exe 30 N:\plots -del 1 D:\plots\10718900860795585473_819076680_3815336_77864
    start /wait Optimizer.exe 30 N:\plots -del 1 D:\plots\10718900860795585473_822892016_3815336_77864
    start /wait Optimizer.exe 30 N:\plots -del 1 D:\plots\10718900860795585473_826707352_3815336_77864

    what I'm doing here is:

    • (mkdir N:\plots) create the folder to write to

    • (start) start a program

    • (/wait) and wait for it to finish

    • using the (Optimizer.exe) in this folder

    • (30) wait 30sec for enough Ram to be available

    • (N:\plots) write files to N:\plots

    • (-del 1) delete input file when finished

    • ( ) I'm not limiting Ram to use. so nothing here.

    • (D:.........) which plotfile to use.

    • (pause) in the end will keep the cmd open so you'll see any errors or that it actually finished all the files

    Obviously the paths to the folders and also the adress and plotfile are individual and need to be changed for your needs.
    And you'll find some more parameters in the README.txt.

    Same thing with the plotter

    mkdir D:\plots
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_807630672_3815336_77864
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_811446008_3815336_77864
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_815261344_3815336_77864
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_819076680_3815336_77864
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_822892016_3815336_77864
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_826707352_3815336_77864

    Here I am using the whole Disk but splitting it into smaller Plotfiles to have some Breakpoints in between. (gaming and such!)

    If you stopped the batch process and want to restart it just use comment marks on the existing poltfiles like this:

    mkdir D:\plots
    ::start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_807630672_3815336_77864
    ::start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_811446008_3815336_77864
    ::start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_815261344_3815336_77864
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_819076680_3815336_77864
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_822892016_3815336_77864
    start /wait gpuPlotGenerator.exe generate buffer D:\plots\10718900860795585473_826707352_3815336_77864

    A good explanation of calculating Plotfile sizes


    haitch ADMIN 4 months ago @BurstL0rd
    @BurstL0rd - Okay, if you want to make the plot the size of your drive:

    Get the size of your drive in bytes - In windows, Explorer -> Properties will show this to you.
    Divide that number by 262,144 (The size of one nonce)
    Divide that number by your stagger size - the last number in the plot file name // 1G=4096 / 4G=16384 / 5G=20480 / 6G=24576 / 12G=49152 / 24G=98304
    Round the number down - eg 335,600.152 becomes 335,600
    Multiply that number by your stagger size.
    that Number becomes your plot size - the third number in the plotfile name
    The first number is your numeric account number, the second number is your starting nonce number - make sure they don't overlap. eg if your first plot starts at 0 and is 335,600 nonces, the second plot should start at 335,600.


    You could also do a combination of both but then you'll probably have to add the paths to the programs like this example:

    start /wait C:\Users\username\Desktop\gpuPlotGenerator-bin-win-x64-4.0.3\gpuPlotGenerator.exe generate buffer D:\temp_plots\10718900860795585473_807630674_3815337_93057
    start /wait C:\Users\username\Desktop\plot_optimizer_gui_1.0.3-j6jq\Optimizer.exe 30 N:\plots -del 1 D:\temp_plots\10718900860795585473_807630674_3815337_93057

    ....and so on. Now you should go on holidays and all Plots are going to be finished and nicely optimized when you get back!)

    Editing these scripts can be tedious! If you use Notepad++ you can do column editing by pressing ALT+Mouse click™ wich comes in handy quite often! Otherwise use Notepad++ carefully. It thinks it's smarter than you!

    So you're still here...! ok. maybe you wana do a bunch of plotfiles under 50GB to upload to Amazon Drive until they kick you!(like me!-/)
    Best way to go is using a Spreadsheet program like for example Libreoffice Calc.

    • Edit your Batch file in there using all the Spaces you need and of course the math functions.

    • Then save it as a .cvs but instead of actually using the comma delete it and use nothing.

    • Then open the .cvs in Notepad++ and maybe do some last editing and save it as a .bat file.

    And boom you've got a mile long Batchfile!) And perfect oversight of you Plotfiles in a Spreadsheet.

    There are surely other ways to do this. But this is as far as I made it up to now!)

    enough for now......

  • Thanks for everyone's help on this issue. I was a bit scared of the cmd option but it worked great! The new file appeared, the old one was deleted and my miner now picked up the new optimized plot along with my 3 other non-optimized ones. Yes, it took about 18 hours for a 1TB file, but that seems pretty normal. I will start tinkering around with a bat file to make this easier in the future. Thanks again!

  • @nixxda said in Plot Optimizer not working - help please:


    sorry to re hash this again I've search and searched for a missing command. this is my command line and it just kicks me out to the empty c:\plots file that I made with the mkdir cmd

    start /wait "C:\burst plots optimizer\plot_optimizer_gui_1.0.3-j6jq\Optimizer.exe" c:\plots -del 1 F:\Burst\plots\7xxxxxxxxxx513_156672_3072 pause

  • @snorklepuss1 put a 0 with space before c:\plots and move the pause to a new line

  • @iKnow0 Thanks Kindly fired right up

  • It's maybe a bit late (as I also understand the workaround was to use the command line), but there's a "solution" for the original issue.
    I also experienced issues with using the graphical interface (it worked for some plots and afterwards no longer).
    The "solution" is to delete the GUI and download another one from the internet. Unblock in the properties of the zip file, decompress and set it up again and then it will work.

    Not ideal of course, but better then nothing. My point is also that if Burst community truly wants to expand and reach everybody you cannot expect other people to fool around in command line prompts. You need to have some technical skills for that and not everybody feels really happy with that.

    It would be great if the GUI wallet (great tool by the way!) would also contain an option to do this kind of optimizing directly.

  • admin

    @SvenE the latest versions of the client does write optimized plots directly with the XPlotter.

  • @SvenE Even me, being a little bit proud of my freshly adopted CMD skills, have started using Xplotter!-) Straight out of the Windows Wallet! Works really nice and is fast!

Log in to reply

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.