GPU PLOT GENERATOR (LINUX X64) issue



  • I finally got my GPU (msi AMD R9 380 4GB). I followed step by step whatis written in the readme.txt file of the GPU PLOT GENERATOR (LINUX X64) pachage from github

    I installed OpenCl via AMDAPPSDK-3.0
    I installed Install the build-essential and g++ packets
    I installed opencl headers (I'm in ubuntu)

    I run

    sudo run make dist
    

    but can not finish the process and I get this error:

    Linking [bin/gpuPlotGenerator.exe]
    /usr/bin/ld: saltato /home/ziomar/AMDAPPSDK-3.0/lib/x86_64/sdk/libOpenCL.so incompatible during the research of -lOpenCL
    /usr/bin/ld: saltato /usr/lib/gcc/x86_64-linux-gnu/6/../../../libOpenCL.so incompatible during the research of -lOpenCL
    /usr/bin/ld: saltato //usr/lib/libOpenCL.so incompatible during the research of -lOpenCL
    /usr/bin/ld: impossible to find -lOpenCL
    collect2: error: ld returned 1 exit status
    Makefile:31: instructions set for "bin/gpuPlotGenerator.exe" not executed
    make: *** [bin/gpuPlotGenerator.exe] Error 1
    

    If I try to run the plotter with ./gpuPlotGenerator I get this error from the already build version you can download from http://burstcoin.biz/download/7-gpu-plot-generator-(linux-x64):

    Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertionneeded != NULL' failed!
    

    I really hope that someone could help me out with this



  • EDIT:

    I solved the error from the already build version by downgrading the AMDAPPSDK-3.0 to AMDAPPSDK-2.9.1

    Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertionneeded != NULL' failed!
    

    Now it works! But if I run

    ./gpuPlotGenerator listDevices
    

    It can see just my CPU