Linux plotting help

  • Hi all
    I am starting to get into burst, and want to start mining with a spare computer. It is running Linux mint 18. (Fresh install)

    I want to start plotting with 250gb on that computer. I got a wallet set up on my main windows box(local wallet). I would like to use a standalone miner on the Linux box to avoid having a wallet installed on that machine.

    I have tried almost all the dcct plotters and they all give me the same error when running the make command. Something about string.h I cannot type the exact command at the moment, but if I need to I will update the post.

    I have tried alternative compiling options and editing some code with no luck, and have had to resort to trying the wallet plotter/miner. In the future I will probably expand to 3+TB once I get this figured out. Could anyone help me with this issue?


  • @Xander52
    Please copy paste your command and the output error so we can see what is going on

  • @ccminer I am running "make" in the mjminer directory (and I have also tried mdcct with the same result.) I get

    --- Compiling for 64-bit arch ---
    CFLAGS=-D LINUX -D AMD64 -O2 -Wall -D_FILE_OFFSET_BITS=64 -m64
    gcc -Wall -m64 -c -O2 -march=native -o mshabal_sse4.o mshabal_sse4.c
    mshabal_sse4.c:20:20: fatal error: string.h: No such file or directory
    compilation terminated.
    Makefile:70: recipe for target 'mshabal_sse4.o' failed
    make: *** [mshabal_sse4.o] Error 1

    Help would be great. I would like to get involved in this project. I have been looking at doing this for a little while and finally decided to start trying it out.


  • @Xander52

    I looks like you do not have installed some requested files.
    By the way in the dcct folder you downloaded and unzipped there is a folder named "bin" there you can find already compiled files, so cd to "bin" from your terminal an launch the command you want from there, it should work.

  • @ccminer There is no "bin" folder in the mddct folder or mjminer folder. I used git clone to retrieve the files. I also followed the install guide and don't think I have any missing requirements.


  • @Xander52 said in Linux plotting help:

    ll guide

    my mystake I'we read DCCT and not mddct.
    I'm sorry but I use a different script to plot :(

  • @ccminer said in Linux plotting help:


    I did try to use DCCT but the download was unavailable.

  • @ccminer I read this and tried the commands that the issuer had posted, then running make and I got it to compile.

  • @Xander52 NIce so now you are plotting already?

  • @ccminer I think so. I started a 50gb test plot. It could take a while though

  • @Xander52 Yeah CPU plotting takes a while, I don't know how much ram you have and what CPU you have but it will takes a while.
    If you can use a GPU and plotting using your GPU it will save you a lot of time!

  • @ccminer I think the GPU is pretty bad. I know it is an Nvidia GPU, but that's about it. The CPU is a athlon 2 core I believe, and I have 3gb ram, but I told it to use 2gb. I also have no idea how to get open CL lol.
    Thanks. Will update if I need more help

  • @Xander52 ok
    in case you will decide to use GPU (I reccomend) just write a new post and sure the folks here me included we will be more than gald to help.
    Welcome to burst and happy bursting ;)

  • @ccminer Thanks. Once I get a few TB drives I will probably do that.
    It does seem to be plotting properly now though
    alt text

  • @ccminer said in Linux plotting help:

    I decided to cancel the plotting and do a 250gb one so that way I have one large plot (don't worry I deleted the old plot)

  • I have been using the updated version of DCCT - the MDCCT plotter and have had a problem.
    The plotter has slowed to a crawl or stopped altogether at 95% complete. My drive is 5TB with a GeForce GTX 750 TI graphics card.

    Here is input to start:

    ./plot -k xxxxxxxxxxxxx587 -x 1 -d /media/imbota/burst/ -s 0

    Working output:

    Using SSE2 core.
    Creating plots for nonces 0 to 18907000 (4959 GB) using 12775 MB memory and 4 threads
    95 percent done.

    Does anyone have an idea as to why this might happen?
    Thanks for any help you can give.

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.