Help with mining in Linux

  • Hello again. I finally managed to plot my drives and found a way to access my headless linux server to leave it mining... the problem now is how to mine.
    I've tried all the softwares and still can't mine using Linux (Ubuntu):

    • Burst Mining System - Error in maven and with JAVA_Home
    • PocMiner - although I follow the instructions, doesn't work
    • Dcct - Still no go.

    After a while, and looking at the software available for Windows users, I have to conclude that Burst is not for Linux users.

    I'm going to try some other options because I still believe this can be a good project but I'm really getting tired of banging my head just to make something work on Linux, when is so easy to do on Windows..

  • I am mining on linux as we speak

    I will post a pic here in a few

    and will post instructions also

  • what i use to mine on linux is

    all i did was extract the files
    then type make
    then cd bin
    edit the miner.conf
    the type ./burstminer

    it is that simple

  • @HotDrive if you for some reason dont have JAVA installed on your system you should.

  • I have java installed but the burstcoinjminer needs to have the opencl sdk installed and i dont have a vid card on this server so makes no sense to install the opencl sdk

  • @Njcfamily31907 Ok, I'll give it a go. But I'm still insisting on one thing: mining in Linux should be as simple as mining on Windows. Maybe someone can make a AIO Wallet for Linux...

  • @LithStud I have JAVA installed (one of the first things I did). But thanks for the reminder.

  • @Njcfamily31907 can't find that file "" anywhere. The closest thing I found was the Uray miner, which has 2 files: burstminer and miner.conf. Can't do make, can edit the conf file, ./burstminer does nothing...

  • @HotDrive Uray miner is more than likely the one @Njcfamily31907 mentioned (the latest release on github is 1.1). it sounds like you downloaded the binary release, the instructions given were for compiling from source. if invoking the binary in a shell returned nothing (i just downloaded and ran on 64bit ubuntu and it returned an error related to the config file) then you could try compiling from source. doing so will require a c++ compiler and make (sudo apt-get install g++ make)

  • @HotDrive edit the mining.conf file with you pool address and the locations of your plots, than open a terminal cd to the miner folder and type ./burstminer and it will start mining

  • Sorry guys, but nothing... I'm really getting frustrated about this... (must be a supreme noob!)

    Is there any Linux miner out there that can treat me as a child and explain all the steps?

    My specs:

    • I have a PC, with 2 cores, running Linux 16.04, 64bits (not headless anymore. added GUI with remote access), with JAVA (OpenJDK Java 8).
    • I have 2 drives
      • One with 3TB, called BD3TB, plots 16444728646700662992_1200000001_11434624_10048
        located at /media/hotdrive/BD3TB/Burst/Plots
      • One with 2TB, called BD2TB, plots
        located at /media/hotdrive/BD2TB/Burst/Plots
    • I mine at

    Don't care for which miner to use, as long as it works.


  • @HotDrive saying "i got nothing" doesn't help with understanding what you are trying or what errors you are getting so please provide descriptions of what commands you are issuing and what the computer is providing as a response.

    ssh access should be enough because the miners are command line. if you have to use gui access open a terminal to run commands.

    to my knowledge jminer will need openCL with video card driver support.

    uray binaries run for me on 64bit Ubuntu 14.04.4 LTS all you need to do is edit the config file. to download and decompress them on a command line:
    tar zxvf burst-miner-r4-linux64.tgz

    now go into the directory ('cd burst-miner-r4/') and edit the mining.conf file (use nano 'nano mining.conf' , vi or you editor of choice) so it looks like:
    "poolUrl" : "",
    "submissionMaxDelay" : 30,
    "submissionMaxRetry" : 3,
    "socketTimeout" : 60,
    "maxBufferSizeMB" : 512,
    "plots" :

    save the file and run the miner:

    if you have a problem provide the command, relevant output and config file.

    sorry if i sound like an impatient ass. trying to provide each step without making assumptions about anything but you need to provide more information about what is going wrong.

  • ...(drum rolls)... IT WORKS!

    @damncourier Thank you (multiply by 1000+), and sorry for my lack of information.
    BTW, you do not "sound like an impatient ass" because I'm not listening to you... actually, I'm reading you. :) And I was the first to asked to be treated like a child, hence, your "impatience" made me take a big step into adulthood ;). I can only thank you (again) for this.

  • @HotDrive so glad it works! good luck with the mining!

Log in to reply

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.