gpuPlotGen error - need help



  • Trying to plot 5TB drive on Ubuntu 16.04 OS. Have everything in place (?), when I go to plot from terminal:

    ./gpuPlotGenerator generate buffer /media/imbota/burst/...9587_0_156000000_200000

    I get error:

    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Loading platforms...
    Loading devices...

    [ERROR][-1][CL_DEVICE_NOT_FOUND] Unable to retrieve the OpenCL devices number

    Can anyone point me to what I am missing? Thanks


  • admin

    @vadirthedark I've not used the Linux version, but that looks like your devices.txt is not configured. Run "./gpuPlotGenerator setup" and configure your card.



  • @haitch, I have in devices.txt: 0 0 2048 256 8192.
    However, when I tried to do ./.... setup I get the same error message.
    I also looked at AMDAPPSDK-3.0 the .sh setup log and didn't see any errors there.
    Seems the part in the plotter that uses the id's in order to run the program is failing?
    The listDevices and listPlatforms 0 work fine.
    Will continue to work on this.
    Thanks for your help.



  • @vadirthedark Have you set up the opencl drivers currently ? Can you mine on the same machine with the GPU miner ?



  • @haitch, Yes I downloaded version 367.57 which is supposed to be the latest for Ubuntu 16.04.
    Here is platforms o and devices output:


    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Platforms number: 2

    Id: 0
    Name: NVIDIA CUDA
    Vendor: NVIDIA Corporation
    Version: OpenCL 1.2 CUDA 8.0.46

    Id: 1
    Name: Clover
    Vendor: Mesa
    Version: OpenCL 1.1 MESA 11.2.0
    [email protected]:~/Mike/crypto/burstcoin/gpuplotgen$ ./gpuPlotGenerator listDevices 0

    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Devices number: 1

    Id: 0
    Type: GPU
    Name: GeForce GTX 750 Ti
    Vendor: NVIDIA Corporation
    Version: OpenCL 1.2 CUDA
    Driver version: 367.57
    Max clock frequency: 1150MHz
    Max compute units: 5
    Global memory size: 1GB 974MB 768KB
    Max memory allocation size: 499MB 704KB
    Max work group size: 1024
    Local memory size: 48KB
    Max work-item sizes: (1024, 1024, 64)

    Systems Settings-Details-Graphics shows: GeForce GTX 750 Ti/PCIe/SSE2. The OpenCL runtime seems to be installed, however,
    Many of the Cuda packages are not. Do you know if Cuda (or Mesa) should be installed concurrent with AMD APP SDK (or Open CL) and/or
    GeForce driver? I am not familiar enough with Linux to understand much of what I read on the Internet. I have not found any
    information related to the error message.
    Thanks for any help.


  • admin

    @vadirthedark Sorry - you've gone way past my knowledge og Linux Mining/Plotting sorry.