Stuck at GPuplotter setup



  • Hi

    I do not know how to set up the below portion in the tutorial. Can anyone advise how to setup platform variable and opencl include/opencl lib variables?

    Modify the [PLATFORM] variable to one of [32] or [64] depending on the target platform. Modify the [OPENCL_INCLUDE] and [OPENCL_LIB] variables of the Makefile to the correct path. Example:

    OPENCL_INCLUDE = c:\AMDAPPSDK-2.9-1\include
    OPENCL_LIB = c:\AMDAPPSDK-2.9-1\lib\x86_64
    Run the following commands :

    cd <this directory>
    make dist
    The [dist] folder contains all the necessary files to launch the GPU plotter.

    I have installed open cl from this link: http://support.amd.com/en-us/kb-articles/Pages/OpenCL2-Driver.aspx

    Thank you.



  • @kaydencc Are you trying to compile and build? If you don't have a reason to compile it then download the ready made one from here: https://forums.burst-team.us/topic/58/gpu-plot-generator-v4-0-3-win-linux



  • @rnahlawi Nope. I downloaded it from the same link. It's just that the instructions in readme in my first post are too complex for me.

    After downloading the plotter, did you need to do modify "platform" variable or "Opencl include"? If yes where did you change the settings?

    Right now I get [ERROR][-61][CL_INVALID_BUFFER_SIZE] Unable to create the OpenCL GPU buffer.

    Device.txt is setup as: 0 0 16192 64 8192

    Gpu is Rx 480 8gb. (4 of them)



  • @kaydencc modify your devices.txt and place these parameters 0 0 8192 64 8192



  • @rnahlawi Many thanks!! It is working now after your suggestion.

    I'm plotting using direct mode in 550gb chunks, to my understanding, there will be no need to optimize plots afterwards?
    This code is used to plot:

    gpuPlotGenerator generate direct C:/burst/9183798047620998523_0_2260992_16384

    Next plot will be gpuPlotGenerator generate direct C:/burst/9183798047620998523_2260993_2260992_16384 and so on?

    Is it also possible to plot using all 4 of my gpus on the same plot? Thanks again.



  • @kaydencc Direct Mode plotting creates optimized plots already, but slower than Buffer mode (I'd personally prefer slow plots which will mine faster later).
    Your Command and next plots are correct, you may add multiple plots in one command instead of waiting one by one.
    for multi GPU, (I also have 4x 480s) I tried below in devices.txt
    0 0 8192 64 8192
    0 1 8192 64 8192
    0 2 8192 64 8192
    0 3 8192 64 8192
    And got little speed boost but NOT as expected 🙂



  • @rnahlawi Cool, shall give it a try. It seems an rx 480 can plot while mining too.

    My first plot of 550gb seems to be done now, but the command prompt show that it's stuck at 2%. However the 550gb plot is ready, and there has been no ram usage or disk activity for half an hour when I view task manager. Do you know if it's complete?

    I tried moving the plot but it says it is in use by gpuplotgenerator.


  • admin

    @kaydencc If the plot is at 2%, but there's no disk activity, check the event viewer - it's possible the display driver crashed. If so, you'll need to delete the plot and start again - it's useless.



  • Ok. I tried the miner which shows this message: file "9183798047620998523_0_2260992_2260992" name/size mismatch
    Guess it's time to replot.

    @haitch Is the percentage being stuck means plotting has failed? I read on the forum the percentage progress might be stuck for a while before picking up the pace, but mine seems to be stuck at 0.36%, with 12288 nouce/min and zero gpu usage. Disk and ram usage is still high however.

    I'm concerned it will be like last time, where it makes a 550gb plot, then cease ram/disk activity with gpuplotter still hanging at 2%.