Why is the Local Wallet so finicky?



  • I ran the local wallet for t least 3 days straight with no problems. I shut down my computer and after restart I tried unsuccessfully to run the Local Wallet. After hours of waiting, I downloaded the current DB and installed it. Still no Local Wallet for 3 hours now.

    Why is this software so touchy? These type of problems intrigue the techno geek but turn off most people (the majority) of the potential Burst community.

    I have read in other threads how people have abandoned Burst because of the bugs, lack of documentation, etc.

    Thoughts?



  • @rds i never had such problems with pure burst client. It might be because the database isnt properly shutdown and thus gets corupted.



  • Hmm never had this happen either. I know sometimes the wallet is still not closed by hitting the x and you have to look at the taskbar next to the win time



  • it's happend to me a few times but i can say it only happen's on the all in one client and started near the begining of dec id get it working but if i closed out the client i have to clean the DB and re DL to get local to work agin , i started just using the online side of the client as that has never failed for me.



  • @LithStud,

    Could you elaborate on the "pure Burst client"? I use the AIO (All in One) version 3.8. I don't use it for plotting, I use a command line bat file. I don't use it for mining. I start the Blago miner straight from the wallet folder. I only reason I use The AIO wallet, other than to see my stats/dashboard, is to supply my solo mining with a "local wallet".

    Is there a standalone (pure) wallet program I could run? Maybe that will fix my problem.

    However, if that is the fix for me, it still does not address the broader issue of having to go into developer/geek mode to make this stuff work. Most people will not embrace a system that is hard to run. Doesn't bode well for Burst longevity.



  • Took me a while to get the All-In-One Local Wallet going. Even after browser downloading the db from haitch's server, it would always tell me java wasn't running. But one day the log in screen randomly popped up - haven't closed it since lol



  • @k.coins ,

    I hear you, but most people shut their computer off once in a awhile. I shut mine off to add an 8GB memory strip in my laptop. I took all of 5 minutes to install the memory and then hours to try to get the local wallet running. Still with no success. And I was aware of the "corrupt" DB issue, so I made sure the Wallet was shut down in an orderly fashion. It didn't matter. And that's my broader point. The Wallet software should be hardened to withstand a disorderly shutdown. Windows always warns about shutting down orderly, but if you don't and you restart, it starts up, Burst local wallet needs that same level of hardness to be a quality piece of software.



  • @rds i have always used https://github.com/burst-team/burstcoin/releases/tag/1.2.7 albeit with my own modifications, but those are for UI only so doesnt affect how java client works. No idea why it might be different for AIO wallet.


  • admin

    @rds you are right. The db shutdown is far from perfect. We are hardening the db against it. Windows and Java are not very helpful as you can imagine.



  • Moved to help and support



  • @LithStud,

    So this (1.2.7) looks like an older version of the AIO wallet I'm using. I guess my question is do you run the wallet from a command line environment or do you run the GUI version where the black screen comes up and asks you to select "online" or "local" and when you select local the message saying wait sits on the front screen forever.



  • @rds its the client itself 😛 its only started by run.bat and you use webrowser



  • OK, so I removed every trace of the Wallet 3.8 and downloaded a new version of 3.8.1.

    I tried to start the local wallet and it started. Downloading the blockchain from scratch. That will take forever.

    I stopped the wallet and replaced the DB files with the 2 DB files I downloaded from team.us. The local wallet does not start up after 10 minutes.

    I stopped the wallet and replaced the DB files with 2 DB files I copied from another machine that runs the local wallet, no problem. The local wallet does not start up after 10 minutes.

    Any help here?

    The local wallet used to work on this machine until I stopped it and restarted the computer the other day.

    The offending machine is windows 10 with 16GB of memory. Java 121 is installed. Wallet 3.8.1

    The computer that runs the wallet no problem is windows 7 with 12 GB of memory and has Java 111. Wallet 3.7.

    I need the Win 10 to run because it has USB 3.0 the Win 7 is only USB 2.0.

    I need the local wallet to run for solo mining.

    Thanks,


  • admin

    @rds Just to clarify, the burst wallet can be found here:
    https://github.com/burst-team/burstcoin/releases

    The AIO Windows Client combines the above wallet and different other burst related software like plotter and miner to a kind of suite, to make it more easy to get started.

    Some prefer using the AIO client, some prefer running the the single software without.

    There is not such a thing like a 'local wallet', just a wallet running local (localhost/your machine). While the 'online wallet' is the same software running on another machine.

    I just thought this things should be clarified ...

    All software included in AIO client can also be found here:
    https://forums.burst-team.us/category/9/burst-software



  • @luxe,

    Thanks,

    What I meant on the GUI there is a bar that offers two options, "online" and "local".

    So as I said before, I don't use the GUI options for plotting and mining so I'm going to download the software from the link you provided. Are there instructions on how to start it up?


  • admin

    @rds In general it should run 'out-of-the-box' ... there is a run.bat included. You may download db or use this guide to speed up sync with network:
    https://forums.burst-team.us/topic/751/howto-use-opencl-gpu-for-accelerated-snyc-with-blockchain



  • OK, I see, the 1.2.7 referred to above is the actual wallet software version. The 3.8.1 is the packaged AIO software.

    I just looked at my Win 7 machine, the AIO is 3.7 with NRS version 1.27.

    The Win 10 machine, the AIO is 3.8.1 but the NRS version 1.26.

    Not sure why the 1.2.6, I just downloaded that today.

    So I'm going to get the 1.2.7 and try that.



  • So I downloaded the 1.2.7 and ran the run.bat file. A command window opened and a bunch of lines appeared. One was that the genesis block was not present. So I assumed it knew to start downloading the database.

    So then I clicked on the localhost:8125 shortcut in the 1.2.7 folder and a webpage opened up with what looked like I see when using the AIO wallet except there was no feature to load a passphrase from the encrypted text file that stores your password.

    Then I loaded the DB files from my win 7 computer and restarted. There was a line saying genesis block detected, after a few minutes it appeared as if the blockchain was up to date.

    So everything seems to work.

    Questions:

    Is there a way to autoload your passphrase on the browser page?

    Do I have to have the the browser page open to solo mine (I guess no).

    How do I send a reward assignment change using this setup? The AIO wallet had fields you fill in on the browser page. Is there a config file that has to be updated?

    Thanks,



  • @rds use localhost:port/rewardassignment.html

    The passphrase loading is a feature of AIO. Here you can do at most by checking that remember me


  • admin

    @rds you do not need to have browser page open while mining.
    for reward assignment you can use the url @LithStud mentioned, there is also a more simplified one:
    http://localhost:8125/rewardassignmentshort.html