GPU plotter questions



  • J:\gpuplot>gpuplotgenerator setup

    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Loading platforms...
    Loading devices...
    Loading devices configurations...

    1. List all devices
    2. List configured devices
    3. Add device config
    4. Remove device config
    5. Save config
    6. Quit

    Select an option: 1


    [0] AMD Accelerated Parallel Processing (OpenCL 2.0 AMD-APP (2117.14))
    [0] Spectre (OpenCL 2.0 AMD-APP (2117.14))
    [1] AMD A8-7600 Radeon R7, 10 Compute Cores 4C+6G (OpenCL 1.2 AMD-APP (2117.14))
    [1] NVIDIA CUDA (OpenCL 1.2 CUDA 8.0.0)
    [0] GeForce GT 730 (OpenCL 1.2 CUDA)


    1. List all devices
    2. List configured devices
    3. Add device config
    4. Remove device config
    5. Save config
    6. Quit

    Select an option: 2

    Number of configured devices: 1

    Index: 0
    Platform: 1
    Device: 0
    Global work size: 2048
    Local work size: 256
    Hashes number: 8192
    Used memory: 512MB


    1. List all devices
    2. List configured devices
    3. Add device config
    4. Remove device config
    5. Save config
    6. Quit

    Select an option:


  • admin

    @ZapbuzZ That looks correct, what's the exact command line you're using ?



  • gpuplotgenerator generate buffer myid 400000001 12021760 8192


  • admin

    @ZapbuzZ That's what I get for posting before having my coffee ...... it should be:

    gpuplotgenerator generate buffer <drive leter>:\myid_400000001_12021760_8192



  • now i got error invalid filename
    where does filename fit in?

    my command was : gpuplotgenerator generate buffer (my id number) 400000001 12021760 8192


  • admin

    @ZapbuzZ the filename specifies the parameters the plotter uses - post the exact command you're using, you can post the numeric ID, no one can do anything with that, except send you Burst ....



  • gpuplotgenerator generate buffer 11481706595869336581 400000001 12021760 8192


    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Loading platforms...
    Loading devices...
    Loading devices configurations...
    Initializing generation devices...
    [0] Device: GeForce GT 730 (OpenCL 1.2 CUDA)
    [0] Device memory: 512MB
    [0] CPU memory: 512MB
    Initializing generation contexts...

    [ERROR] Invalid file name


  • admin

    @ZapbuzZ do:

    gpuplotgenerator generate buffer <drive letter>:\11481706595869336581_400000001_12021760_ 8192

    eg: gpuplotgenerator generate buffer e:\11481706595869336581_400000001_12021760_8192



  • Loading platforms...
    Loading devices...
    Loading devices configurations...
    Initializing generation devices...
    [0] Device: GeForce GT 730 (OpenCL 1.2 CUDA)
    [0] Device memory: 512MB
    [0] CPU memory: 512MB
    Initializing generation contexts...
    uh owe gpuplooter has stopped working windows error



  • maybe this was coded in foreign code pages



  • changed the config slightly a few times didnt work either


  • admin

    @ZapbuzZ double check your devices.txt - in the output earlier it was showing using platform 0 device 1, which is your AMD, but the plotter output is showing it using the nVidia, which is platform 1 device 0



  • same result windows error ony its the AMD chip that did it this time i didnt try admin rights i'll try that now



  • J:\gpuplot>gpuplotgenerator generate buffer j:\11481706595869336581_400000001_12021760_8192

    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Loading platforms...
    Loading devices...
    Loading devices configurations...
    Initializing generation devices...
    [0] Device: GeForce GT 730 (OpenCL 1.2 CUDA)
    [0] Device memory: 512MB
    [0] CPU memory: 512MB
    Initializing generation contexts...
    [0] Path: j:/11481706595869336581_400000001_12025856_8192
    [0] Nonces: 400000001 to 412025856 (2TB 888GB 0MB)
    [0] CPU memory: 2GB 0MB

    Devices number: 1
    Plots files number: 1
    Total nonces number: 12025856
    CPU memory: 2GB 512MB

    Generating nonces...
    0.00% (0/12025856 remaining nonces), 0.00 nonces/minutes, ETA: 22y 49w 0d 6h 56m 0s...
    [ERROR][-36][CL_INVALID_COMMAND_QUEUE] Error in step2 kernel finish

    got further this time


  • admin

    @ZapbuzZ Try changing the 8192 to 4096



  • didnt work

    Generating nonces...
    0.01% (1536/12025856 remaining nonces), 3177.93 nonces/minutes, ETA: 2d 15h 3m 41s...
    [ERROR][-36][CL_INVALID_COMMAND_QUEUE] Error in step2 kernel finish

    J:\gpuplot>gpuplotgenerator generate buffer j:\11481706595869336581_400000001_12021760_8192

    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Loading platforms...
    Loading devices...
    Loading devices configurations...
    Initializing generation devices...
    [0] Device: GeForce GT 730 (OpenCL 1.2 CUDA)
    [0] Device memory: 128MB
    [0] CPU memory: 128MB
    Initializing generation contexts...
    [0] Path: j:/11481706595869336581_400000001_12025856_8192
    [0] Nonces: 400000001 to 412025856 (2TB 888GB 0MB)
    [0] CPU memory: 2GB 0MB

    Devices number: 1
    Plots files number: 1
    Total nonces number: 12025856
    CPU memory: 2GB 128MB

    Generating nonces...
    0.02% (2048/12025856 remaining nonces), 3321.08 nonces/minutes, ETA: 2d 12h 20m 27s...
    [ERROR][-36][CL_INVALID_COMMAND_QUEUE] Error in step2 kernel finish



  • This post is deleted!

  • admin

    @ZapbuzZ If it's plotting, then yes, your screen is going to become very laggy due to the load on the GPU. You can use task manager to kicj the priority down to low, but it's still going to lag.



  • turns out 3120 nonces per minute for this graphics card as opposed to 3650 nonces per minute with the wplotgenerator. I can't expect much from a discreet nvidia anyhow lol thanks for your help guys using cpu lets it function without lagging one day i'll buy a big fat super dooper double slotter 🙂



  • now i got the correct way to start this plotter when i do have a bigger card 🙂