creepMiner - C++ Burst Miner (based on Uray's Miner)



  • @ZapbuzZ no problem, ask as much as you want 😃
    Mininig intensity is the amount of threads that are simultaneously checking plot chunks for nonces.
    The more drives you have, the higher this value should be. There is a physical limit for your computer, but you have to find it by yourself. Depends on many factors like drive read speed, buffer size, CPU and RAM speed, and so on.



  • Ok, here is release 1.2.0

    > forward (proxy) function
    > solo mining
    > passphrase en/decryption
    

    Here are some additional informations:
    https://github.com/Creepsky/creepMiner/wiki/Solo-mining
    https://github.com/Creepsky/creepMiner/wiki/Forwarding
    https://github.com/Creepsky/creepMiner/wiki/Setting-up-the-miner



  • yipii!-) just at the right time! trying to get the cuda miner to run!


  • admin

    @Creepsky Awesome, thanks for all your hard work in development and documentation.



  • @luxe thank you, it's a big pleasure for me and if some of you are interested in my work it's even more fun 🙂

    @nixxda please tell me if you have any difficulties, I tested it only on my machine (GTX 1060, Win 10)



  • @Creepsky crashes after it got the first Blockinfo!? @GTX970

    do you see something wrong in my .conf?? something I'm missing?

    OOhh! this just got very messed up after the first start!-) (let me try again) (edit: cpu worked befor)

    {
        "maxBufferSizeMB" : 128,
        "miningInfoUrl" : "http:\/\/burst.ninja:8124",
        "miningIntensity" : 3,
        "output" : {
            "debug" : true,
            "dir done" : false,
            "error" : {
                "request" : false,
                "response" : false
            },
            "last winner" : true,
            "nonce confirmed plot" : false,
            "nonce found" : true,
            "nonce found plot" : false,
            "plot done" : false,
            "progress" : true
        },
        "passphrase" : {
            "algorithm" : "aes-256-cbc",
            "decrypted" : "",
            "deleteKey" : false,
            "encrypted" : "",
            "iterations" : 100,
            "key" : "",
            "salt" : ""
        },
        "plots" : [
            "D:\\plots",
            "E:\\plots",
            "H:\\plots",
            "K:\\plots",
            "M:\\plots",
            "N:\\plots",
            "O:\\plots",
            "P:\\plots",
            "Q:\\plots",
            "R:\\plots",
            "S:\\plots",
            "T:\\plots",
            "F:\\plots",
            "I:\\plots",
            "J:\\plots",
            "L:\\plots"
        ],
        "poolUrl" : "http:\/\/burst.ninja:8124",
        "serverUrl" : "http:\/\/127.0.0.1:8080",
        "submissionMaxRetry" : 3,
        "targetDeadline" : "0y 0m 1d 00:00:00",
        "timeout" : 45,
        "walletUrl" : "http:\/\/127.0.0.1:8125"
    }
    


  • @nixxda config is ok. It looks messed up because the miner transforms it into RFC 7159 comform state, but this should be all right 🙂

    I think the problem is that I compiled it only for my architecture. I added now all architectures and uploaded it again, hope this helps: https://github.com/Creepsky/creepMiner/releases/tag/2.2.0.
    If not then I have to debug it on another computer.



  • No! sorry to say something went wrong with this build! (or at my end!)
    It was however good enough to find a 10sec Block right after I started it!!-)

    If I use cpu, the cpu usage goes up to 80%, local server is not running and the .conf gets messed up!-/
    Cuda crashes after it shows the first Blockinfo (and also messes with the .conf)
    My GTX970 is on 376.33 (378.49 crashes jminer! lots of reporting to do!)

    tried spelling of IP's like "localhost", "127.0.0.1" and "192.168.1.3" ; "maxBuffersize" ; online and local wallet.
    and out of paranoia editing with notepad, notepad++ and Brackets

    this is what mining.conf should look like:

    {
        "maxBufferSizeMB" : 128,
        "miningInfoUrl" : "http://burst.ninja:8124",
        "miningIntensity" : 3,
        "output" : {
            "debug" : true,
            "dir done" : false,
            "error" : {
                "request" : false,
                "response" : false
            },
            "last winner" : true,
            "nonce confirmed plot" : false,
            "nonce found" : true,
            "nonce found plot" : false,
            "plot done" : false,
            "progress" : true
        },
        "passphrase" : {
            "algorithm" : "aes-256-cbc",
            "decrypted" : "",
            "deleteKey" : false,
            "encrypted" : "",
            "iterations" : 100,
            "key" : "",
            "salt" : ""
        },
        "plots" : 
        [
            "D:\\plots","E:\\plots","H:\\plots","K:\\plots","M:\\plots","N:\\plots","O:\\plots","P:\\plots","Q:\\plots","R:\\plots","S:\\plots","T:\\plots","F:\\plots","I:\\plots","J:\\plots","L:\\plots"
        ],
        "poolUrl" : "http://burst.ninja:8124",
        "serverUrl" : "http://127.0.0.1:80",
        "submissionMaxRetry" : 3,
        "targetDeadline" : "0y 0m 1d 0:00:00",
        "timeout" : 45,
        "walletUrl" : "http://127.0.0.1:8125"
    }
    }< this is an copy paste error! if you find it you can keep it!-) ( only happened in here!)
    

    If I can assist you in anyway tell me! I'll do anything except coding!-/



  • @Creepsky said in creepMiner - C++ Burst Miner (based on Uray's Miner):

    @nixxda config is ok. It looks messed up because the miner transforms it into RFC 7159 comform state, but this should be all right 🙂

    I think the problem is that I compiled it only for my architecture. I added now all architectures and uploaded it again, hope this helps: https://github.com/Creepsky/creepMiner/releases/tag/2.2.0.
    If not then I have to debug it on another computer.

    jey!!! works! kinda sorta..... (cuda)
    0_1485995444201_Unbenannt.JPG

    local http is still not running but I might have to do a restart first! been messing around..........



  • @nixxda for the local server you need an extra setting, seems like I have deleted it 😕 will add it again, sorry:

    "Start Server" : true
    

    Ok, first step done, now I need to fix the strange nonce error. 🙂
    May I ask how the CPU usage and speed is while mining a block with cuda?



  • @Creepsky said in creepMiner - C++ Burst Miner (based on Uray's Miner):

    @nixxda for the local server you need an extra setting, seems like I have deleted it 😕 will add it again, sorry:

    "Start Server" : true
    

    Ok, first step done, now I need to fix the strange nonce error. 🙂
    May I ask how the CPU usage and speed is while mining a block with cuda?

    wait, I'm in a restart!-) (everything!!)
    nonce error was only on the first Block! all good now! Cpu usage goes to 40-50% with cuda. I'll add the server bit and try.
    see you after the reboot........



  • now we're talking!-) do you think I can lower the cpu usage by getting the "maxBufferSizeMB" vs "miningIntensity" right?
    And I think the "strange nonce error" is an bad response from burst.ninja! I get those sometimes from the ninjas. But a lot less with your miner! (I`ve seen none with 1.4.9)

    btw. my very small wish list: little popups with Block height and deadline in the "Deadlines" graph!-)

    Zeit um ins Bett zu gehen!-)

        "Start Server" : true,
        "maxBufferSizeMB" : 128,
        "miningInfoUrl" : "http:\/\/burst.ninja:8124",
        "miningIntensity" : 3,
        "output" : {
    "
    "(and so on)
    


  • @nixxda hard to say, maybe if you set miningIntensity to 1 and maxBufferSizeMB to a higher value (512 perhaps).
    But the problem is that you have a lot of plot drives and for every one an own thread is created.
    Maybe I should add a setting for max plot readers.

    This and the popups come directly on my Todo-list 😉

    Ja wird langsam Zeit 😛



  • uhh, if I fiddle with those "switches" I can get some real bad "mouse lag"!-)

    however, read time with cuda is down to ~30sec @83TB! nice!

    gute nacht!



  • Hey @Creepsky, this looks great! I have a couple of questions if you don't mind...

    • Will creepMiner forward nonces for other miners like jminer or Blago's miner? Or will it only forward nonces for other creepMiners?
    • Can creepMiner forward without mining?
    • Can creepMiner forward multiple miners to a local wallet for solo mining?

    Thanks!



  • @zyzzyva said in creepMiner - C++ Burst Miner (based on Uray's Miner):

    Hey @Creepsky, this looks great! I have a couple of questions if you don't mind...

    • Will creepMiner forward nonces for other miners like jminer or Blago's miner? Or will it only forward nonces for other creepMiners?

    He added something like this I think. https://github.com/Creepsky/creepMiner/wiki/Forwarding

    • Can creepMiner forward without mining?

    Dont know!-/

    • Can creepMiner forward multiple miners to a local wallet for solo mining?

    wouldn't you want to point them all directly?? otherwise see answer 2

    Thanks!

    @Creepsky might already be in bed! its nearly 3am here in europe!-)
    tomorrow...................



  • Thanks @nixxda! It's late here too. Maybe I'll try some of this out tomorrow...



  • @nixxda I'm here but half asleep x)
    30 seconds is better then I thought :-| the GTX 970 is way better then the 1060!

    @zyzzyva thank you 🙂

    • Yes it can forward every miner. For them it looks like the forwarding creepMiner is a normal pool/wallet.
    • Forwarding without mining is not possible yet (but on the Todo-list)
    • Yes, you can also forward multiple miners.

    The idea was to simulate a pool/wallet, so the other miners can send the commands they normally would send.

    Gute Nacht all! 😃



  • little "heads up"!
    "cuda-creeper " has been doing quite well so far.
    one error message I saw and could not really make sense of:
    0_1486047652704_creeperror.JPG

    and a few others of which I know are related to my "distance" to burst.ninja
    (some day when I'm really bored I'm going to try ssh-tunneling;-)
    So I changed pools and went to tross's and all of those are gone.

    I've also been trying some different settings for "maxBufferSizeMB" and "miningIntensity".
    But I have not found anything better than the standart settings so far.
    Infact I think I saw the miner finding different (more) deadlines on the same Block (after restart) while trying out those parameters!
    So today I left all on standart and checked regularly against jminer and could never confirm that!-)

    CPU usage is still a bit high and read times are not quite at jminers level, but damn close!
    I'm very happy having this "alternative" miner for my nividia graphics card!
    And man, check out all this documentation! Thats new;-)



  • 0_1486071326337_upload-eb11a75e-f863-4718-8a5f-f3456416b4d4

    deadline shows different at pool.
    miner says 21 days on pool 379742 years
    BURST-HXWG-DMBT-2Q4H-B3GRF