How to setup jminer when AMD and nVidia GPU in one PC



  • Hello miners.

    I insert AMD RADEON 480 and nVidia GeForce 1080 GPU board in my PC.
    gpuProtGenenerator can find two boards.

    ----
    [0] AMD Accelerated Parallel Processing (OpenCL 2.0 AMD-APP (2236.10))
        [0] Ellesmere (OpenCL 2.0 AMD-APP (2236.10))
        [1] Spectre (OpenCL 2.0 AMD-APP (2236.10))
        [2] AMD A10-7800 Radeon R7, 12 Compute Cores 4C+8G  (OpenCL 1.2 AMD-APP (2236.10))
    [1] NVIDIA CUDA (OpenCL 1.2 CUDA 8.0.0)
        [0] GeForce GTX 1080 (OpenCL 1.2 CUDA)
    
    ----
    

    But Jminer can't start.

    C:\Users\Hajime\Burstcoin\mining.ninja-B>java -jar -d64 -XX:+UseG1GC burstcoin-jminer-0.4.6-SNAPSHOT.jar 
    22:14:54.500 [main] INFO burstcoin.jminer.JMinerApplication - Starting the engines ... please wait!
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ff8693470cd, pid=7964, tid=0x00000000000026d4
    #
    # JRE version: Java(TM) SE Runtime Environment (8.0_121-b13) (build 1.8.0_121-b13)
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.121-b13 mixed mode windows-amd64 compressed oops)
    # Problematic frame:
    # C  [nvopencl.dll+0x3870cd]
    #
    # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
    #
    # An error report file with more information is saved as:
    # C:\Users\Hajime\Burstcoin\mining.ninja-B\hs_err_pid7964.log
    #
    # If you would like to submit a bug report, please visit:
    #   http://bugreport.java.com/bugreport/crash.jsp
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    
    ---------------  S Y S T E M  ---------------
    
    OS: Windows 10.0 , 64 bit Build 14393 (10.0.14393.0)
    
    CPU:total 4 (4 cores per cpu, 1 threads per core) family 21 model 48 stepping 1, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, avx, aes, clmul, mmxext, 3dnowpref, lzcnt, sse4a, tsc, tscinvbit, tscinv, bmi1
    
    Memory: 4k page, physical 32439256k(28349216k free), swap 47996888k(42752936k free)
    
    vm_info: Java HotSpot(TM) 64-Bit Server VM (25.121-b13) for windows-amd64 JRE (1.8.0_121-b13), built on Dec 12 2016 18:21:36 by "java_re" with MS VC++ 10.0 (VS2010)
    

    How to set what environment what parameters?

    Thank you.



  • @Hajime In the jminer.properties check the OPENCL sections

    I copy here:

    The miner uses openCL for most of the mining calculations, ensure it is setup correctly.
    Instructions can be found e.g. here (thanks cryo):
    https://github.com/bhamon/gpuPlotGenerator/blob/master/README.md
    You could also use that instruction to find your platformId and deviceId if needed.

    platformId - id of openCL platform on your system. one platform may have multiple
    (default:0) devices, the miner currently uses just one (in general not the bottleneck)

    deviceId - specifies the device used by OCLCecker, can be your first GPU,
    (default:0) in most cases it will not be 100% used. (depends on capacity)


    platformId=
    deviceId=

    try to edit there with your cards infos and restart the miner



  • @Hajime I get an similar error when trying to run jminer 0.4.7 on my nvidia GTX970 with the newest driver v378.49 !
    with the nvidia driver v376.33 everything works fine!

    I dont now which card your trying to use but if its the 1080 your settings in "jminer.properties" would be:

    platformId=1
    deviceId=0
    

    Hope that helps!-)



  • @ccminer Thank you for reply.
    I set this parameter. But java occur error before run jminer.



  • @nixxda Thank you for reply.
    I think that too. So I tested 0.4.7 snapshot and 0.4.6 release. But java did not work.
    What your Windows environment variable (OPENCL_LIB)?



  • @ccminer @nixxda Sorry. java run.

    C:\Users\Hajime\Burstcoin>java -jar -d64 -XX:+UseG1GC burstcoin-jminer-0.4.6-SNAPSHOT.jar
    23:57:01.894 [main] INFO burstcoin.jminer.JMinerApplication - Starting the engines ... please wait!
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffe8e7c70cd, pid=11640, tid=0x0000000000002c2c
    #
    # JRE version: Java(TM) SE Runtime Environment (8.0_121-b13) (build 1.8.0_121-b13)
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.121-b13 mixed mode windows-amd64 compressed oops)
    # Problematic frame:
    # C  [nvopencl.dll+0x3870cd]
    #
    # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
    #
    # An error report file with more information is saved as:
    # C:\Users\Hajime\Burstcoin\mining.ninja-B\hs_err_pid11640.log
    #
    # If you would like to submit a bug report, please visit:
    #   http://bugreport.java.com/bugreport/crash.jsp
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    

    I disabled AMD RX480 board. but occurred same error.



  • @Hajime maybe @luxe is the right person to help you due that he wrote the miner



  • @Hajime Downgrade your nvidia driver, this worked with me



  • @rnahlawi Bingo! Now jminer run on driver version 372.70

    But mining speed do not faster than RX480.

    $300 RX480 > $600 GeForce GTX 1080

    lol! lol...



  • @Hajime I prefer RX480 over Nvidia. and Nvidia 970GTX on top of latest 10xx series.


  • admin

    @Hajime Sorry for the problems ... i don't know why lastest drivers have issues with jocl.org, the lib used by jminer. Will hopefully fixed in the near future. I also had problems with latest AMD drivers and after i go back to version 16.11.5 ... everything works fine.
    I heard NVIDIA cards do not perform very good compared to AMD in terms of openCL.

    But it is not always the problem of the GPU speed, ensure your card uses full PCIe speed, if it just uses PCIe x8 instead of x16 this may slow down a huge mining operation.
    alt text



  • @luxe working with me on 16.12.1. Slower, but I think cause i connected the card on riser. Will connect the card to 16x slot on next drive and confirm speed.

    0_1486326261188_upload-3ff39a20-dbfd-480b-b722-adfba358e595


  • admin

    @rnahlawi Just do not change just because there is a higher version, may result in a lot wasted time get it running again 🙂 Latest version is 17.1.2 ... http://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-Crimson-ReLive-Edition-17.1.2-Release-Notes.aspx ... if someone did check or want to check ... give us a hint if it works.



  • @luxe Thank you for reply
    I look GPU-Z at first time. Oops...
    0_1486328615143_radeon.png 0_1486328695017_geforce.png

    I go to a bed!


  • admin

    @Hajime click on that questionmark and run the test to ensure displayed is right, it may be displayed wrong if gpu is idle.



  • @luxe Thank you for advice.

    I tested one GPU board in my PC and measured easy benchmark.
    GeForce GTX 1080 280MB/sec ave
    RX480 360MB/sec ave
    RX460 280MB/sec ave

    GPU-ID said RX460 do not support OPEN CL but can plot and mining.

    Conclusion: CPU power is insufficient. I give up.

    0_1486348333156_cpu.png 0_1486348340570_GeForceGTX1080.png 0_1486348353067_rx480.png 0_1486348362019_rx460.png