Plot optimizer - disk activity 100 % with 0 KB/s read or write



  • I am trying to optimize the plots from disk A to disk B (4 TB seagate both of them, same type). In the beginning the optimization process works, but then after a seemingly random amount of scoops, it will say in Task Manager that the empty disk B has 100 % activity with 0 KB/s read or write. Obviously there is nothing going on, and the only thing I can do is pull out the USB to be able to close the optimizer window and then try again.

    SMART status is OK and I have scanned disk for errors and none are found. Anyone know why this is happening, or what I can do to fix it? I am able to mine with disk A, so both disk and plots should be OK.

    Update: I see that disk A has used space 4 000 460 570 624 bytes (3,63 TB) and disk B has free space 3 988 014 321 664 bytes (3,62 TB). Is the error I mentioned Optimizer.exe's way of telling me that there is not enough room for writing out the optimized plot file?

    The difference in space may be due to disk A being 64k cluster size and disk B being default cluster size.

    Update 2:
    Tried formatting with 64k cluster size , which gave me enough space, but got me the same error.


  • admin

    @Propagandalf Do you use it with gui? Errors are show with very low contrast at the bottom of the window.
    alt text

    Ensure, there are no deleted files on that target drive, empty recycle bin. (But you formatted, so this is not the case.)



  • That hasn't happened to me yet but I can say a few things. Larger cluster sizes in regards to plots shouldn't be an issue. It does look like the destination disk is too small. In such instaqnces i would recommend trying this:

    if the destination capacity is full, stop the optimiser. The data that fits can then be checked with plotchecker which will scan and rename the optimised "shorter" plot decreasing its reported size accordingly. However, the optimisers cache that keeps the optimised plot contiguous when writing may become lost (why destination has a small percentage of free space.) Also, try running optimiser at command prompt instead if you find the destination disk has no data written. (even if there is a filename which should be deleted in due course) by meaning, skip the java GUI.



  • @ZapbuzZ @luxe
    Thanks for the advice. I have optimized successfully before with different drives on a different system, using command prompt only. I was using command prompt this time as well, with 3 GB cache. The optimizer program does not produce any errors when my issue happens, it looks as if it is still running, except it never progresses because the disk is running 100 % with no activity (what a contradiction). If I disconnect drive B, drive A will start being read from again, but obviously that won't help because it will have nothing to write to anymore. The issue happens very early, within 5 minutes, so I'm likely not filling the drive, and the last time I tried I know I had more space than needed.

    I suspect that something is wrong with the disk even though I could not find errors when I scanned it for bad sectors and checked SMART status. Are there any other programs I could run to figure out if the drive is faulty?



  • The random issues with the plot optimizer and the amount of time it took have led me to switch to Xplotter which optimizes as it goes. Speed is still a bit of an issue takes me about 24hrs to plot 1TB but there's no optimizing required



  • @socal
    Yeah I definitely see your point 🙂



  • xplotter is great but has anyone used a plot for like 6 months to see if optimiser could step in and tune it up? anyhow it could also be your installed ram causing issues. there are tools that can test your memory bank for errors. you would deftineately know if hard drive is failing if you did a full slow format of your disk that is not recording. smart has been known to not work correctly. A tool called speedfan can ask your drives smart to self test some hard drive manufacturers supply tools also.



  • @Propagandalf sometimes USB drives have and additional partition with some software on it. If that is the case then you will need to delete both partitions, then create a new one to avail of all the disk space.