Singling out one HDD for changing write cache settings



  • Does anyone know a way of singling out a single HDD when changing write cache settings? For instance, if I go via Disk manager, I can choose the specific disk I want, but when I go further and into Hardware/policies to change write cache settings, I only see a long list with all the different HDDs I have connected, with no obvious way of differentiating between them.



  • Go to device manager and select the "volumes" tab next to the policies tab. It will show you which drive it is, then you can adjust the policies as required.



  • @rds Do you mean to locate the drives via "Portable devices" inside Device Manager, and then go to "volumes" tab et cetera? Because when I do that the only tabs I have available are "General - Driver - Details - Events".



  • @Propagandalf ,

    not portable drive, "disk drives". These are win 10 screenshots, win 7 is slightly different but same essence.

    0_1487429966844_upload-fb991af6-0e65-4898-96ed-08c185bf62a7

    11111
    Select one::
    11111

    0_1487430023292_upload-2dcf74f0-63a5-4664-bb5d-c629d5b9a630



  • This is interesting topic. I have a internal drive connected via usb externally. This drive has one 2tb plot. What is the difference if I change the setting from default Quick Removal too....

    0_1487430696389_upload-b1b2a0ac-9600-4ffb-be09-419c7a7e49f0



  • @rds Ah, thanks, but those are the same windows I was able to access through disk manager. I am still not able to see the actual name that I have given the hard drive in there, and I cannot see where it is mounted either, so I will not know which HDD I am changing the settings for because I have many...

    @Burstde Enabling the write cache and maybe also the bottom option will likely increase the effectiveness of your SMR drives (typically 8TB Seagate drives) when you are plotting to them. If you have ever plotted to an SMR drive you will know what I mean 😉 I was able to find a workaround though, let me know if you need to know.



  • @Propagandalf

    you have to go into volumes and hit the populate button. The drive letter will show up.

    You said you had a workaround to SMR, I would like that info. I'm CPU plotting, if it's GPU it's N/A for me.

    Speaking of SMR, I have Seagate 4TB Backup plus, which I'm pretty sure are SMR drives. Do you know about the Seagate Extenstion drives? These are the no power supply USB 3.0. I have them as well and I decided to try to plot the entire drive on one file. It feels the slowest of all. I did a backup plus with 37 - 10TB files and it was way quicker than what I'm doing now. Insight appreciated.



  • @rds Amazing, thanks! I did not know that. 🙂

    My workaround was for GPU plotter in buffered mode (sequential write), but maybe the theory behind it can apply to CPU plotting as well. I got extremely low speeds when using a high stagger and trying to plot a whole 8 TB disk at once. The way I got it working was setting a 1 GB stagger and only plotting half the disk (4 TB). Also, something that may be part of the workaround, was that I plotted 10 drives at the same time, so maybe that 'evened out' the plotting load somewhat. I reckon that the SMR drives cannot handle too much 'hammering' of writes at the same time.

    CPU plotting with Xplotter uses random write for optimized plotting I believe, so that is likely a whole different scenario for SMR drives. One thing I haven't tried yet is enabling the write cache before trying to plot optimized. I think many 4 TB drives and smaller have write caching enabled by default, but SMR drives (usually bigger drives) have write caching disabled by default.



  • Yes changing my 8tb drives to match my post above, improved the mb/per second.
    They are connected through a thermaltake duel usb drive but getting zeros nice



  • @Burstde said in Singling out one HDD for changing write cache settings:

    Yes changing my 8tb drives to match my post above, improved the mb/per second.
    They are connected through a thermaltake duel usb drive but getting zeros nice

    What was your initial write speed and what was your new write speed? Were you plotting optimized or unoptimized?



  • 33mb/s to 50mb/s. Again usb connected for now. All plots are not optimized

    0_1487433331649_upload-62b43322-91e6-4e7a-84ee-218abd4ec218



  • @Burstde

    I found the write cache enabed/disabled did not make a difference in overall speed. I too, write multiple files at the same time to allow one file to calculate nonces while another is writing. If I can get 30-50 MB/s I can write a plot file at my displayed nonces/sec but randomly the plotter will slow down to 1-2 MB/s on one or both files, then pick up to a good speed. There is no pattern. I shut the plotters off and restart, sometimes they go fast other times no. I have resigned myself to just walk away and come back in a day and see another 1% complete.



  • @rds @burstde So at least it seems to improve mining speed then. For the moment I have given up trying to plot SMR drives optimized, so I optimize them afterwards. But, optimizing seems to take a long time as well with write speeds of about 25-30 MB/s. I'm wondering if this is normal because it is SMR, or if it is because I plotted them using only a 1 GB stagger. Nevertheless I will try to turn on write caching next time I optimize one of these disks, to see if the optimization process can maybe improve.