Slow Wallet Node and Sync Issue



  • I have a problem with the Burst wallet node on one of my machines and I'm struggling to get it resolved.

    The Burst wallet was running fine until last week, when it would no longer sync up.

    I've deleted everything, and done a new install of Burst 1.2.7 with a fresh folder and download the full blockchain file and put in correct folder.

    The Burst node is very slow to open it starts in 1230 seconds, and fails to stay sync'd and I copied a sync'd folder from another machine and within a few hours the node was 50 blocks behind.

    I think it could be the Java version causing the issue but I use the same on another machine I think Jre8. This machine is Win.8.1 and everything the same works on my Win10 machine.

    Any ideas? It's like a caching issue or something.


  • admin

    @RiskyFire
    A lot of transactions being spammed this days ... means more work for wallet.
    Ensure you run 64bit java ... on command line ...

    java -version
    

    Should spit out something with 64bit ...

    Is the Win 8.1 a slower machine?



  • Do you know that there is a new version ??? You do not want to change it for some reason and I'm messing around.
    It seems that something is going faster, but I must also say that today the network has been a bit slow
    http://forums.burst-team.us:4567/topic/4019/new-wallet-version-1-2-8



  • @Energy yes, I noticed too that the sync goes faster with the new version.



  • @luxe said in Slow Wallet Node and Sync Issue:

    java -version

    Microsoft Windows [Version 6.3.9600]
    (c) 2013 Microsoft Corporation. All rights reserved.
    
    C:\Users\Username>java -version
    java version "1.8.0_111"
    Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
    

    The machine has a A10 7700K, and runs well. But Burst doesn't seem to put any load on the cpu or memory.

    I'll check the Win10 java version. What version are you all running?

    My Win10 machine is running the same version of java

    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.
    
    C:\Users\Lee>java -version
    java version "1.8.0_111"
    Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
    
    

  • admin

    I don't think is has something to do with java version ... 64bit java8 should be fine ...

    java version "1.8.0_92"
    Java(TM) SE Runtime Environment (build 1.8.0_92-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.92-b14, mixed mode)
    


  • I switched to 1.2.8 but I'm getting the same problem. It appears to be due to the blockchain file.

    I'm going to re-sync the node from scratch and see how it goes. It's started and is downloading at least.



  • @RiskyFire keep an eye on it tho at some block numbers it gets stuck and needs restart (it was same in previous version at least for me) from recent blocks it seems it gets stuck at block 330000.