Error 1004 Reward Recipient [SOLVED]



  • OK guys this is the issue I'm having, I ran my miners about 4 days ago just to test my plots (every few days while plotting I stop and mine for a few hours to make sure everything works) everything worked fine I went to run them yesterday and I keep getting the Error 1004 your reward recipient doesn't match the pool's address.

    I know how to set my reward recipient so I went I redid it, same issue.
    So I reset the reward recipient on all my accounts to the desired one (pool.burstcoin.eu) and it just will NOT change my reward recipient from (burstpool.ddns.net) I just keep getting the Error 1004s.

    Yes I waited 4 blocks before mining, yes all plots have the same ID so I only have to worry about one reward recipient, I set all of them to pool.burstcoin.eu just in case.

    I have used both the Blago miner standalone and the AIO Wallet miner (which is the exact same version of Blagos Miner lol) I get this issue on both programs.



  • @socal I also have the newest release of the AIO Wallet and for the record I went ahead and switched my reward assignment to burstpool.ddns.net since that's the pool my wallet is forcing me to mine on anyway since it isn't recognizing my reward recipient changes.

    If anyone can help me fix this not only will I appreciate it but I will move my miners back to pool.burstcoin.eu



  • @socal u on the right port?


  • admin

    @socal try the assignment on https://wallet.burst-team.us/rewardassignment.html , and if you get an error - post it here.



  • If you're using blaggos CPU miner,
    Navigate to:
    C:\Users\USERNAME\AppData\Roaming\BurstWallet\miner-burst-1.160705
    and open miner.conf in a text editor such as notepad++ etc.
    Check its settings to see what pool and port it's set to.

    Also I've seen some pools in the past where:
    the address on the web interface doesn't match the actual pool address for the reward assignment
    the address given from the drop down list in the AIO wallet doesn't match the pools address for the reward assignment

    But that was months ago. These issues may have been fixed in the latest wallet update. As I recall the error message displayed from the miner listed the correct pool address and thats the one you should use when setting the reward assignment. It was months ago that I ran into this type of problem so I'm typing from memory. I believe you can go into the miner.conf, set the pool and port, run the miner and it will tell you what the correct reward assignment address should be for that pool. Try that.



  • @TrickyHunter I am trying to use pool.burstcoin.eu on port 8124 and yes in Blagos Miner everything is set correctly.



  • @haitch aaaaand of course as soon as i set my reward recipient using the link you gave me and adam does another rain and clogs the system



  • @haitch said in Error 1004 Reward Recipient:

    https://wallet.burst-team.us/rewardassignment.html

    UPDATE ok I redid my reward recipient (again) using https://wallet.burst-team.us/rewardassignment.html and I am STILL getting the "Error 1004: Your Burst accounts reward recipient does not match the pool's address" its still saying my RR is set to burstpool.ddns.net and the funny thing is I NEVER set it to that pool before this issue started occurring.

    God I hope I don't have to replot everything AGAIN.


  • admin

    @socal This is on the BURST-TFTW-Q22L-PJGD-2JWU4 account? The reward assignment isn't showing - passphrase definitely correct ?



  • another interesting development.....When I switch from mining on pool.burstcoin.eu to burstpool.ddns.net it doesn't give me reward recipient errors it starts mining and submitting DLs right away even though I have my RR set for pool.burstcoin.eu. It's like my Reward Recipient updates are not taking effect. and YES I have set my RR on all my accounts even though all my plots are plotted with my miners ID just in case its some sort of plot ID issue


  • admin

    @socal Do the reward assignment again, and post the output here. The RA is not showing on the blockchain



  • {"signatureHash":"bc3009c4aa7ad158db4b7ae18b31b6fe01f1ed3308704e2dac4d719973cfdc30","unsignedTransactionBytes":"141004a4c804a005d231552b7f1b0c4ae6e451c08c5ca43fa67b5c5ba403d61e77c6013b7d459f631bfcd2d481bc5dff000000000000000000e1f50500000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000e100500525976f3482cb59001","transactionJSON":{"senderPublicKey":"d231552b7f1b0c4ae6e451c08c5ca43fa67b5c5ba403d61e77c6013b7d459f63","signature":"df9bc459e50fc321d9fcd11b6e3edfd7408d17ca0303e30ce20ee6d59f5c23069f5cc5f16c3bf98feb7d134387291eb850412b13c01b1f473e2a6a0941a07a9b","feeNQT":"100000000","type":20,"fullHash":"3ad6419e00d6ab9b0903c1fe9617510cd23daf0904e24fa982bfdb11c3f8f909","version":1,"ecBlockId":"10427289204080138578","signatureHash":"bc3009c4aa7ad158db4b7ae18b31b6fe01f1ed3308704e2dac4d719973cfdc30","attachment":{"version.RewardRecipientAssignment":1},"senderRS":"BURST-TFTW-Q22L-PJGD-2JWU4","subtype":0,"amountNQT":"0","sender":"102334502154319676","recipientRS":"BURST-7Z2V-J9CF-NCW9-HWFRY","recipient":"18401070918313114651","ecBlockHeight":331790,"deadline":1440,"transaction":"11217294595039811130","timestamp":80258052,"height":2147483647},"broadcasted":true,"requestProcessingTime":34,"transactionBytes":"141004a4c804a005d231552b7f1b0c4ae6e451c08c5ca43fa67b5c5ba403d61e77c6013b7d459f631bfcd2d481bc5dff000000000000000000e1f505000000000000000000000000000000000000000000000000000000000000000000000000df9bc459e50fc321d9fcd11b6e3edfd7408d17ca0303e30ce20ee6d59f5c23069f5cc5f16c3bf98feb7d134387291eb850412b13c01b1f473e2a6a0941a07a9b000000000e100500525976f3482cb59001","fullHash":"3ad6419e00d6ab9b0903c1fe9617510cd23daf0904e24fa982bfdb11c3f8f909","transaction":"11217294595039811130"}



  • Thats for BURST-TFTW-Q22L-PJGD-2JWU4 which is my personal account NOT the account I mine or plot with but I reset it just now any way


  • admin



  • the account I am trying to change and it keeps giving me the 1004 Errors is the asset account BURST-8GQC-9FPW-2CB2-BGWN9 which since I just set it to use burstpool.ddns.net to test mining I will post my RA hash once I change it again.

    All plots have been plotted with BURST-8GQC-9FPW-2CB2-BGWN9 account ID (17930413153828766298) and that is also the account I use for mining (since its for the asset) and yes my passphrases are correct since I have to use them to A) log into the wallet and 😎 I am copy pasting the passphrases to mitigate any "fat finger" accidents


  • admin

    @socal said in Error 1004 Reward Recipient:

    BURST-8GQC-9FPW-2CB2-BGWN9

    That shows succesful transfers to EU then to Tross. Check the ID on the plots, should be: 10652013929523526346



  • son of a bitch



  • somhow my plot IDs got changed......how the hell does that happen? anyway to fix that or do I have to replot?


  • admin

    @socal replot, unless you know the passphrase for the wrong ID