GPU Ploting-Getting Pissed

  • OK this the 3rd time I've tried to plot these 3, 4TB PMR HDDs and I am starting to get pissed. I have 88TBs more still to plot and I am seriously about to pull my hair out!! The first 2 times I ran the gpu plotter and tried to plot all 3 on the same command prompt window-the HDDs had the plot file written to them- filled up the space (I saved 6GB of room on each) and then after they were written on I looked back and the nonces dropped to like 14-15/min with an ETA of about 2 years. I noticed the first time that the HDDs had spun down and thought that may have been the problem since I had enabled cache on the drive, so I stopped, deleted the file, formated the drive agaqin and plugged the externals into different USB 3.0 ports thinking the hub may have been the problem as well. Did it again and dumbass me didn't fix the spin down problem so when the first drive finished first writing it spun down and again the nonces dropped to a super low number. Stopped, formatted drive again, fixed the spin down issue and then ran each drive on its own gpuplotter command prompt window, so 6 days later first drive finishes and GUESS WHAT??? The damn nonces/min dropped AGAIN and is at 15.65/min with a 1y 44w ETA-WHAT THE HELL IS GOING ON???? they didn't do this with the other drives I plotted with gpu! I have a RX480 8gb card and 32MB of ram witch I'm using 8MB for each drive. THEY ARE NOT SMR drives, as I checked with crystaldisk to find out what kind they were and the specs show PMR. I have turned the cache writing on or whatever for the drives and they are not turning off. on Resource monitor there is a c:\pagefile.sys reading something which is tied into the gpuplotter process because I have singled out to monitor gpuplotter resources. Somebody please before they lock me up into a mental institution HELP!

  • This post is deleted!

  • @Han-Solo thanks smartass

  • @SilverSlonny When you do "direct" plot with the GPU plotter this is normal behavior. (The drive is filled with an empty file then that file is filled up, the nonces per min is only accurate while plotting in buffer mode.(as far as i know).
    Remember also this is a community, people here donate their time to help others, ranting and shouting does not help.

    Re:pagefile.sys ( this is the windows OS swap file, it will always be in use.)
    Re:saving space, this is normal ( 1 plot = 4096 scoops) 4096 will almost never fit exactly to your free disk space, hence leaving a few GB unplotted. This again is normal behavior,

    Might i suggest, use the GPU plotter to plot in "buffer" mode(only 1 drive to start). Then you can optimize the plot to another drive, this way you will get better feedback and you can also mine while optimizing.

  • admin

    @SilverSlonny I can understand your frustration, we all had to find our best way to create plotfiles, i personally never liked the direct mode in gpuPlotter, others like e.g. @haitch did. So everyone has other preferences. I suggest, first find your best way to plot, than start 'mass' plotting.
    I personally used gpuPlotter and plot optimizer like @iKnow0 suggested. GpuPlotter with buffered mode and than optimize to another drive, while optimize is in progress you can start plotting 3rd drive with gpuPlotter etc. I also had good results with xplotter, takes little longer but all in one operation.

  • admin

    @SilverSlonny Plotting in direct mode does that - once you realize what it's doing you'll understand the crazt numbers, but initially it is extremely frustrating. Unlike xplotter which creates the empty plotfile in one step, gpuplotgenerator directly does is block by block, which will take hours where the plotter appears to do nothing and the time expected to complete is measured in years, then it starts filling it in - the nonces/min value is meaningless - it'll continue to increase when filling in the file, but is only accurate at the very end of the plot.

  • @SilverSlonny which CPU do you have? If its a fast one you might consider just to use xplotter.

  • First Thank you for taking the time to read my post and help me. @iKnow0 we've talked for a bit before and I hope you know I wasn't yelling at anybody or anything nor would I, I was just literally going crazy trying to figure this out. @PummelHummel I have an AMD FX 6100 - 6 core 3.3GHz.

    @luxe @haitch
    I am definitely plotting right now in direct mode. What I may not understand is this- It took 36 hours to write the first file (to fill up the space on the HDD) then its been like 2 days of it going in and slowly filling in. The nonces are increasing and 2 out of the 3 drives are about 25% complete, but from everything I read it shouldn't take this long should it? I just fear maybe I'm doing something wrong that is making the plotting take abnormally wrong. I have a pretty good system with a decent cpu, 32GB of RAM, a RX480 8GB card, so to me I shouldn't be taking 6 days to do some 4TB drives, right? I understand the process does take time but from other peoples input on the forum they are finishing 4TBs in about 36 hours vs 6 days (hopefully it finishes by then lol). I am going to try various ways, but if someone could take the time to check out my process when I start a new set of drives I would really appreciate it. I just got another order of 28TBs and these drives are starting to stack up, but I'd hate to tell my supplier I can't take them because now I am getting them for $10/TB because of my volume buying, but if I can't plot them faster than every 6 days its not worth it LOL

  • admin

    @SilverSlonny with it taking that long, I assume they're SMR drives - they take forever to plot. Just be patient.

  • @haitch I check the drives with crystaldiskinfo and got the model number- looked it up and they are PMR - I thought that may have been the issue but it wasn't.....I know strange...the only thing I can think of is my device setup may have been wrong? here is what the listdevice gave me. See if you see anything I may have done wrong please
    i put- 0 0 4096 256 8192 -as my setup

    Id: 0
    Type: GPU
    Name: Ellesmere
    Vendor: Advanced Micro Devices, Inc.
    Version: OpenCL 2.0 AMD-APP (2264.11)
    Driver version: 2264.11
    Max clock frequency: 1330MHz
    Max compute units: 36
    Global memory size: 8GB 0MB 0KB
    Max memory allocation size: 3GB 976MB 0KB
    Max work group size: 256
    Local memory size: 32KB
    Max work-item sizes: (256, 256, 256)

    Id: 1
    Type: CPU
    Name: AMD FX(tm)-6100 Six-Core Processor
    Vendor: AuthenticAMD
    Version: OpenCL 1.2 AMD-APP (2264.11)
    Driver version: 2264.11 (sse2,avx,fma4)
    Max clock frequency: 3322MHz
    Max compute units: 6
    Global memory size: 31GB 1005MB 244KB
    Max memory allocation size: 7GB 1019MB 317KB
    Max work group size: 1024
    Local memory size: 32KB
    Max work-item sizes: (1024, 1024, 1024)

  • @luxe I don't like gpuplotter at all, I prefer xplotter instead, the reason is because for me it's a waste of time to plot and then optimize it. At the cost at my time I can use xplotter and have the plots optimized already.

  • @pr0cesor but with direct mode gpuplotter is optimized

  • @SilverSlonny Sure but gpuPlotter does not work as it should be, the fact that one of the admins mentioned that he does not like it neither indicates that there is more into it. I don't know the exact details but I tried gpuPlotter in both modes and I am not satisfied at all.

  • yeah, I'm not liking it too much either right now--still working on these same 3 drives. one is at 65%, one at 62% and one at 60%. I still can't help but think I did something wrong lol. Where is Cryo? isn't he the one who made it? and maybe he could take a look at what I did and let me know what I maybe did wrong? Cryo???? Cryo???? or whoever made gpuplotter are you there? 😉