stratum_subscribe timed out problems

  • This isn't related to Burst mining, but the community here is quick and knowledgeable, so I thought I'd ask here.

    For the last couple of days, my miners haven't been able to connect to stratum. All I get is constant "stratum_subscribe timed out" message. I've tried multiple pools and multiple coins (e.g. decred @suprnova, xmg @suprnova, ftc @coinotron, xmg @coin-magi, etc.) No new hardware or software on my machine. I just out of the blue got this. My net is good, can still stream, play games, mine Burst. I also tried rebooting modem/router, no luck.

    Anyone have some advice? How to go about troubleshooting? I have idle hardware and it's killing me!

    Windows 10 x64
    Wolf's m7m cpuminer
    Various flavors of ccminer

  • @IncludeBeer You do manual config? try changing to SSL config as most pools switched to secure protocols or use NiceHash or Minergate for auto configuration.

  • @rnahlawi Well, the same configs I've been using for some time, yes. And they were all working up until a couple days ago. Seems more like a network issue. What do you mean, SSL config? I'm guessing this would be dependent on the miners as well as pools?

  • Update: Really weird: I grabbed the latest version of Nicehash to give it a try: it will mine fine on algos that don't use ccminer, but when it switches to something that does (e.g. lyra2v2), I see in the ccminer window nothing but "stratum_subscribe timed out, retry after 30 seconds...".

    Why would I only have stratum issues with ccminer???

  • @IncludeBeer Try to change nicehash country (EU, US) if it worked, then you are blocked on current one.

  • @rnahlawi Thanks, but no, same result on all other country pools (tried china and japan too :D)

  • @IncludeBeer Last thing to check is your windows firewall (AV APP) changed during Windows update or so

  • @rnahlawi Well, I disabled it and gave it a try: still unable to connect with any ccminer or minerd implementation. It was indeed updated (but that happens nearly everyday). I'll try minerd from my work laptop and on my home network tomorrow. That should help me narrow things down. Maybe try rolling windows back from a previous restore...

  • @rnahlawi Finally figured out the issue: my router was blocking. I bought a long enough ethernet cord to plug my tower directly into my modem and verified that I could mine again with ccminer and minerd flavors over stratum. So, I simply reset my router and everything is fine.

    So much headache for a simple 5 minute solution!