Got no response for wallet request ... trying to solo mine with creep miner 1.5.2 and Problem with Wallet 1.2.8 (it suddenly stucks) connection lost, Block behind, Block not accepted, Creep Miner doesn't find nonces. (solved)

  • Hi,

    i'm trying to start solo mining with creep miner 1.5.2 and now i got stuck and don't know what to to do. Could there something wrong with my wallet (using 1.2.8 Wallet) or is there a problem with creep miner configuration. Did i set the url in the right way ? The miner starts but there is always the message:

    Got no response for wallet request '/burst?requestType=getAccount&account=...'

    Testing with 8 TB

  • @BurnMe

    Sorry about off topic, but solo mining with less than 110TB? 😛 You should be pool mining tbh 😛

  • This post is deleted!

  • OK, i got the solution for my issue, the local wallet sends no response, so when you are setting an online wallet like the message "got no response .... " disappear. I set the local wallet to the config of the creep miner and this was the problem. I think mining on itself is is working correct even with the message im talking about.

  • @BurnMe hmm ok. The request '/burst?requestType=getAccount&account=...' is for fetching the name of the account. It is just an additonal info, and mining is not affected by it.

    If it is working with the online version, you may have to change some option of the local wallet to allow these requests. Maybe some other admin/mod/developer can give you more infos on this.

  • @Creepsky45 thank you very much for your answer. Are you the developer of creepMiner ? Now in the config of creep miner im using the online wallet url, it doesn't matter.

    Now im testing the forwarding. Really good work. I will send you some burst in the future when mining is successfull for me.

    As the creepMiner developer can you answer me a question to forwarding ?

    So i followed your wiki for forwarding. Why don't you connect all devices direct to (creepMinerServer) A ? why D to B and then A ? Can i connect B,C,D direct to A.
    I want: B to A + C to A + D to A and the A to pool and wallet.

    Can i configure for B, C and D the local server i startet in A ?

    There is no need to start the local Server in B,C and D right ? So i can set in the config false , right ? Only starting the server in A, right ?

    When im using 4 pc with 10 TB and connect them with forwarding, is the chance to win a burstcoin like using one physical rig with 40 TB ? How many PC can use forwarding at the same time ?

    is my hypothetical setup working ?

    Thanks for your answer.

    It would be nice when you update the wiki with solo mining step by step for those who are new to burstcoin and don't know what to do and how to configure the url (you don't need to do this its just a note, actually the wiki still is very helpful for using the creep miner, the best i found for burstcoin 🙂 )

  • @BurnMe I am the developer, yes.. I cant login in to my old account (@Creepsky), so I have this account here.
    Thank you for the feedback, I'm glad you like the miner! If you are missing features, found a bug or have questions, just tell here or on github.

    Can i configure for B, C and D the local server i startet in A ?

    You can connect B, C and D directly to A and turn their local server off. I made the example in the wiki that complicated just to show that you can make a chain of miners of any length.

    When im using 4 pc with 10 TB and connect them with forwarding, is the chance to win a burstcoin like using one physical rig with 40 TB ? How many PC can use forwarding at the same time ?

    It is the same like 1 PC with 40 TB, but should be faster, because 1 PC normally needs longer to read 40 TB compared to 4 PCs with each 10 TB (with higher consumption of course).

    You can connect a lot of miners but I cant say how many exactly (> 100 should work without a problem). Depends a lot on the power of your forwarding computer A (network, CPU).

    It would be nice when you update the wiki with solo mining step by step for those who are new to burstcoin and don't know what to do and how to configure the url (you don't need to do this its just a note, actually the wiki still is very helpful for using the creep miner, the best i found for burstcoin 🙂 )

    Thanks for the hint, I will try to make it more clear.

  • admin

    @Creepsky45 Do you need me to reset your password ?for the Creeepsky account ?

  • @haitch in the past I logged in with github OAuth, but somehow it disappeared.
    Now I use twitter OAuth, but unfortunately it is not the same account.

  • admin

    @Creepsky45 There was an issue with the SSO that was preventing regular users from logging in, and we couldn't determine which SSO Plugin had the problem, so I disabled all of them. SSO is currently Broken, but standard login works for everyone.

  • @Creepsky45 Hello Creepsky, like you wanted now i have an idea for a new feature. Just look at my last post, there i got the issue that my local wallet was 2 Blocks behind the actual Block and over a couple of hours i thought everything is running fine until this moment a looked at the actual Block on the pools and

    A good new feature for the creepMiner would be that its automatically controlling the actual Block that is used and compare it with the Block that is used online on the pools and compare it with

    I know the pool get stuck too in the past, but perhaps you know another possibility to proof if the right block is on work and the block 2 rounds behind the real block. An Error message in the Terminal should be shown so that its easy to see thats something wrong.

    After a lot of trying i was able to set Solo mining with creep miner. I tested it with forwarding from another PC and its working quite fine. On the Sreverpage in the browser where you can see all informations there you can see but the port is missing, so when you click on that is displayed you get an error message from the browser and you have to set the port manually. It would be nice if the port is already standing on the serverpage like and then you can click it and the wallet loging appears.

    In conclusion creepMiner is still working good and fine software.

  • Its me again, i solved my problem with the message "got no response for wallet request". I set the wrong wallet address. I set https but you have to set it without s. For those who try solo mining on Linux and CreepMiner here is the setting for solo mining in the config.

    "urls" : {
    "miningInfo" : "",
    "submission" : "",
    "wallet" : "" (don't set https: that was my fault)

    Now i take care of my next issue that the creepMiner suddenly stops when the wallet sends the message block not accepted. Look at my new request. When i found the solution for that i let you know.

    Testing on and don't give up with Linux 🙂

  • @BurnMe that explains the "could not get..." errors 🙂
    Because of the other issue you have - it came up some months ago, and I thougth I fixed it.
    Here is the issue on github:
    I'm currently fixing it and will immediately inform you as soon as it is finished .

  • Thanks creepsky for your active help. I want to sent you some more information of the issue of creepminer stopping after the wallet message "block not accepted".

    When i only restart the creepminer it seems to run normal but i can see it runs totally out of sync. It's mining on old blocks that are already done. So when the CreepMiner stops on wallet message "block not accepted" i first have to restart the local Wallet (1.2.8) and then restart the CreepMiner then it's mining with the actual block and it's working the right way until the next message of "block not accepted" is displayed by the terminal of the wallet. Then restart of wallet and CreepMiner again and so on and so on and so on ........

    I'm no developer but i think its not the CreepMiner at all. Or the CreepMiner has problems in communicating with the wallet after it gets stuck and stops. So perhaps there is an issue with the wallet 1.2.8. too. I have to restart the wallet again everytime and everytime its some blocks behind the real block as i can see in CreepMiner.

    So as developer you can think about this. Could it be that the CreepMiner is crushing the wallet, or the wallet the creepMiner, I don't know the dependeces on programming. So its just another hint for you for troubleshooting.

    When i realy go on mining with creepminer under Linux and its working over the long run there are some BURSTS for you in reservation :), i'm thankful for all developers who makes it possible to mine burstcoin and active help. Keep on the good work and good luck on troubleshooting.


  • @Creepsky45

    i tested on with CreepMiner and i am thinking that the main issue cuold be the wallet or the combination of CreepMiner and wallet 1.2.8.

    After some time I got block error again an then suddenly disconnected to then internet by my router because of to lot traffic. The wallet 1.2.8 uploaded over 50 GB in a few hours and my router blockes that huge upload time by time so i get stuck.

    Now i made these settings in the wallet 1.2.8.

    Announce my IP address/hostname to peers and allow them to share it with other peers.
    If disabled, peer networking servlet will not be started at all.

    Maintain active connections with at least that many peers.

    With these settings the local wallet was running fine over hours first time (i made router settings to allow the traffic). And its still running on with CreepMiner mining in the right way. I can see my Sever in the map of nodes in

    But suddenly the Server disappeared on the map without any error message in the terminal of the wallet and the CreepMiner is mining on as nothing has been happened. No error message too. But i can see that no more nonces are found and submitted. On the actual block. After restarting (only) CreepMiner with the same wallet still running the CreepMiner ist finding and submitting nonces on the same block as before the CreepMiner didn't find any nonces on the same block. The Sever is still not seen on the node list in !

    For me its getting more strange as before.

    Now i don't get the message "Block not accepted" and first i thought it didn't stuck like before but now my server (from the Wallet) disappears in the node list under without any error message ( the wallet terminal looks fine at this moment) and the CreepMiner ist now working on but cannot find any nonces and so there is no submitting.

    I think the Wallet 1.2.8 has somehow an issue on solo mining and the CreepMiner cant handle this issue and even try's to mine and mine or the miner stops with the message "Block not accepted" from the wallet terminal and when i made the new settings to the wallet config like i told in the top of this post, then the wallet runs over hours fine the miner aswell until the miner suddenly cannot find any nonces (although finding nonce after restart on the same block).

    Everthiny is getting more strange and more complex.

    Im testing on and tell the results.

    Has anybody suggestions for good settings for the wallet 1.2.8 so that peer connections are not disabled but not 50 GB upload traffic within few hours ? So why nobody has the same issue?

    When i'm the only one with these strange behaviour of the wallet or CreepMiner then it could be a wrong config from my side, so let me know and perhaps you know how to solve.

    BurnMe thanks for all help.

  • @Creepsky45

    So its me again and now its a little bit more clear to me.

    1. nxt.shareMyAddress=false (If disabled, peer networking servlet will not be started at all), so its clear that there is no "block not accepted warning" from the wallet because i have not started peer networking servlet at all when set to false. So with no netwerking servlet it think its not possible to get the wallet message "Block not accepted" beacuse there is no connnection to a out of time sync server from another peer, right ?

    2. That the creepMiner suddenly stops finding nonces could be an new issue that has nothing to do with stopping on the message "block not accepted" by the wallet. Perhaps this issue is a stand alone issue.

  • @BurnMe hmm you might want to check your rebroadcast settings in

    maybe your rebroadcasting too often, also havent read everything so not sure if you allready did it but when solo mining try to submit only very low deadlines (like 12h and less) otherwise there is a lot of traffic generated without actually being of any use.

  • @LithStud Hi, my deadline now is at 20 days, i know its too long im not realy mining, im just testing with 3 small optimized plotfiles. I want to understand and know how to config.

    Before creating a mining rig it has to work over about 2 Weeks without an issue or real error with my small (and cheap) rig. For testing its goog not for mining, but when solo mining is not working because there are a lot of software issues it would be crazy first to buy additional hardware and then to learn that's not working. So my small testing rig is good for that what it is for.


  • @BurnMe well i am using windows just not AIO and not solomining, so not sure where the problem creeps out pun intended 😃

  • OK i tried pool mining under Linux too. This is working very stable and easy with Linux. I checked the AIO in Windows. But the AIO Software cannot be so configurated like i want to. I want the whole control of plotting and nonce creating, the amount of RAM i am using during plotting. So all this can i do easily with Linux.

    Pool mine just works fine and stable with the creep Miner. But not with solo mining. So i think the changing here is that i don't use the online wallet any more, now im using the local walletl with bring up an Server in my own. And with own local Wallet (Server my problems began. Sometimes stopping mining by CreepMiner, then the wallet block(s) behind the actual block that is used, Block not asccepted and then the CreepMiner stops, Wallet works but creep Miner stops finding nonce with no reasons and so on .....

    So the only thing that i changed on solo mining is that im using the local wallet and therefore i think here is the issue and something wrong and the online wallets are more stable (when no DDos attack).