Help mining on Linux

  • Hello,
    I’m having some issues with mining on Linux. Plotting using the mdcct with dcct-gui software from the burst software page goes okay. Mining is where I run into trouble. In the dcct-gui when I select mine burst and put in the pool then point to my plot I get
    xterm: Can’t execvp dcct-mine: No such file or directory

    With the dcct-gui anytime I do something in the gui, the terminal put up
    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged

    I’ve tried using burst-miner-r4 to mine but I get the error
    {“errorCode”:1007,”errorDescription”:”The deadline for your nonce is REALLY BAD: 3 months, 13 days, 17 hours, 17 min,25 secs -wrong block? Are your plot files corrupted?”}
    over and over again.
    I’ve tried redoing the plots many times, and optimizing.

    Ubuntu 16.04 VM on proxmox
    plots are 200GB


  • This post is deleted!

  • Ho dogfarts :),

    i am testing minig on Linux like you. And now im running a small test miner on a pool under Linux 🙂 .

    Follow these setup:

    Software to plot: dcct-gui
    Software to optimize: dcct-gui
    Software to mine: creep miner (very good software with wiki and good explanations on the downloadside, poco installing only worked for me as admin (not as user, as user i got error messages) then make as user the compilation of creepminer like it is told in the wiki )

    Now to your problems:

    "xterm: Can’t execvp dcct-mine: No such file or directory" i don't know if this was my error message. but i had trouble for using dcct-gui too and i solved the xterm message by (re)installing xterm as admin. xterm installing as user didn't worked for me there was something wrong with the xterm installation.

    I tried mining with dcct-gui too but still not usable for me.

    I looked around for a good Linux miner and the best i found was creepMiner.

    Just search creepMiner with google and you find the github, where you can download it. Click on releases and download the version 1.6.0.

    For me its working very fine. The miner is actually managed by a developer who still is working on, so its getting better and better and problems are solved with each softwareversion. (Im just testing but when i get some burstcoins in the future i want to support the developer because his creepminer is the only way for me to mine with linux in the way i want to do, if this is working for you think about this).

    For testing it is good to make small plots then you don't have to wait so long for creating and optimizing plots when troubleshooting and creating new plots

    Your message:
    "With the dcct-gui anytime I do something in the gui, the terminal put up
    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged"

    I just ignored this message in the terminal, make some plots and then optimizing and creep miner is working fine, everything is alright, so no need to troubleshoot.

    And with the message your Deadline is to long, then you have to add a lot of space. Look a the pools there are some guys with 50 TB and more.

    If my answer is helping you to setup mining with Linux, let me know and send a reply.

  • @BurnMe Thanks for the reply!!!

    Yes, this is a big help. I will check out creepMiner.

    Thanks again!!!

  • @BurnMe thanks i am going to try this too...

  • @BurnMe Looks like creepMiner is working!
    Thanks again!!!!

  • @dogfarts Ok its goog. Im still testing with creep miner. Now i'mt testing solo mining with running the local Wallet and the creepconfig set to Just now i found that For solo mining the miniginfo url should be set to because when it is set to the wrong block is send as information. in the creep miner i can see the block 359221 and this block has already been done. I don't know where the problem is, i'm thinking the burstcoin 1.2.8 is wrong working. So folks you have to set the on mining info to get the right block. I will make an new request for this problem on its own.

    Dogfarts can you try solo mining and tell me what block is sent to your mining info.

  • @BurnMe I'll see what I can do.

  • Look at my new post, there i post the solution i found on a old post from 10/2016. This worked for me fine. But you can try it too and post a reply on my new post. I want to if this error was on my own or somone else got this error. I try to contact creepsky to which a feature that automatically is controlling the right block because when you 2 Block behind on solo mining the whole Mining RIG is running for nothing.