Linux creepminer



  • Hi all, coming from windows and transitioning to linux has proven to be a challenge thus far. I have a few questions as to setting up the miner because although it is running i dont seem to be getting a single DL.

    Do i need to have the wallet installed on this computer? i have it installed on my windows machine so unless it is necessary i would rather not.

    I can't figure out where i am supposed to put my wallet id. the miner is running and i am getting the following on repeat:


    22:27:32: block# 361796
    22:27:32: scoop# 3876
    22:27:32: baseTarget# 844521
    22:27:32: --------------------------------------------------
    22:27:33: Dir /home/viking/Burst/ read (1 files, 93.00 GB total) in 0.339s (~68.48 MB/s)
    22:29:43: --------------------------------------------------
    22:29:43: block# 361797
    22:29:43: scoop# 3511
    22:29:43: baseTarget# 810336
    22:29:43: --------------------------------------------------
    22:29:43: Dir /home/viking/Burst/ read (1 files, 93.00 GB total) in 0.363s (~64.

    This looks very similar to my windows machine (without the DL confirmations ofc) so i think i am on the right track.

    Any help would be much appreciated.


  • admin

    @Creepsky may help you.


  • admin

    @viking 93GB is very small plotsize ... depending on the pool you use, you will not be able to commit a valid deadline/share every round/block. Ensure the targetDeadline of the pool you use is as high as possible ... also it would be good to choose a pool, that pays out after a given time, and not only if a given amount is reached.
    @whateverUsayman suggested http://m.burst4all.com:8124/ earlier today in such a case.



  • yes its a test plot size. i didnt want to commit time plotting my external hard drives because they take a long time to plot if i made a mistake and had to restart. this is a test run to get it working, once i understand it fully i will bring over some of my large HDD.

    i have just looked at the log files and im getting this:
    19.05.2017 21:07:25 (0, src/Response.cpp, 51, Error): Error on receiving response!
    No message received
    19.05.2017 21:07:25 (0, src/Response.cpp, 53, Error): Stackframe
    main (in "src/main.cpp", line 41)
    Miner::run (in "src/Miner.cpp", line 36)
    Miner::getMiningInfo (in "src/Miner.cpp", line 360)
    Response::receive (in "src/Response.cpp", line 29)

    any idea what it means and what could be the cause? its doing it on repeat!


  • admin

    @viking sry shame on me, i have no experience with creep miner, yet. But i'm sure he will respond to you, as soon he has the time. But seams you just got some connection timeout there ... may happen if pool not available or under heavy load ... if it just shows up from time to time and miner not crashing ... could be not that big issue.



  • okay, maybe this version of the miner doesnt show DL stuff.

    I am still curious about the wallet issue though, how can the miner know where to send the burst if i havent entered my wallet url anywhere?


  • admin

    @viking the pool knows your account and will send the reward there ... all wallets sync via blockchain ... so you can access your account from were you want ... does not only exist in single wallet instance.



  • Also there's no problem bringing over plots. The only time you need to replot is when switching accounts. If your just switching miners you can move plots around all you want



  • Is that true even when switching operating system?


  • admin

    @viking yes



  • Hi guys,

    I just started trying to get burst mining to work on linux (mint).

    I plotted (successfully yay!) 500GB using mdcct

    I then tried using the web burst wallet (wallet.burst-team.us:8125). I've managed to get 1 burst using a faucet and have been able to change my wallet name (scprv55). My burst address is BURST-9Z82-84QM-6ECJ-B2RBC

    I then tried the local wallet and that also seems to work.

    Next step was to start a miner and I'm using creepminer which seems to be running fine but I've not seen any 'results' yet

    These are the urls in my config

    "urls" : {
    "miningInfo" : "https://pool.burst-team.us:8125",
    "submission" : "https://pool.burst-team.us:8125",
    "wallet" : "https://wallet.burst-team.us:8125"
    }

    Does this sound like I've got it working right?



  • @scprv55
    Try

    "urls" : {
    "miningInfo" : "http://pool.burst-team.us:8124",
    "submission" : "http://pool.burst-team.us:8124",
    "wallet" : "https://wallet.burst-team.us:8125"
    }



  • @Creepsky45

    Thanks for the suggestion.



  • and what is the URL at the bottom meant to be? or is that one to be left alone?



  • @viking do you mean:

    "webserver" {
       "url": "..."
    }
    

    This is the url for the webserver the miner can start.
    If you set it for example to localhost:8080, then you can enter localhost:8080 in your favorite browser and access the webinterface of the miner.



  • @Creepsky45 yes that is what i meant and i tried it out, definitely a cool feature!
    you did an awesome job with this stuff, it seems packed full of features.

    I am having issues though I seem to be getting this message in the log files:

    21.05.2017 13:48:18 (0, src/Response.cpp, 51, Error): Error on receiving response!
    No message received
    21.05.2017 13:48:18 (0, src/Response.cpp, 53, Error): Stackframe
    main (in "src/main.cpp", line 41)
    Miner::run (in "src/Miner.cpp", line 36)
    Miner::getMiningInfo (in "src/Miner.cpp", line 357)
    Response::receive (in "src/Response.cpp", line 29)

    any idea what that could be?

    thanks



  • @viking "No message received" means the pool did send an empty response to your mining info request. Without the mining info, the miner can't mine.

    If your miner says something like "Dir abc read (n files, n TB total) in n.s (~n MB/s)" then you are mining and you can ignore the error. Like luxe said, sometimes the pool is under heavy load and can't respond in time to your request, but after a while it should work.

    Do you get deadlines?



  • @Creepsky45 well if that's not the problem, then I'm struggling to figure out what is.

    I'm not sure how to check deadlines on your miner, so I'm not sure. It's not showing up on the terminal.

    Just to satisfy my curiousity I installed linux on my windows machine just to compare it to my new rig on the off chance it was a hardware issue, but I'm getting the same issues.

    I'm getting SOME DL but much much less than I did on windows with the official wallet and miner, this is the same machine with the same hard drives installed. The only difference is linux.

    I MUST be doing something wrong here, xubuntu is so much less imposing on the system then windows, it makes no sense that it should be having a negative effect.

    What would you recommend?

    Thanks.