Error launch miner



  • Hi
    I have one question , one i run ./run.bat i get this output.

    Exception in thread "main" java.lang.UnsupportedClassVersionError: burstcoin/jminer/JMinerApplication : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at org.springframework.boot.loader.LaunchedURLClassLoader.loadClass(LaunchedURLClassLoader.java:94)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:46)
    at org.springframework.boot.loader.Launcher.launch(Launcher.java:87)
    at org.springframework.boot.loader.Launcher.launch(Launcher.java:50)
    at org.springframework.boot.loader.JarLauncher.main(JarLauncher.java:51)

    i have instaled java 8 on a macbook pro

    Can someone help me ?

    Thanks


  • admin

    @StefanoB I would say you do not have Java8 ... please check your java version with:

    java -version
    

    And post result here.

    --
    Moved to Help&Support


  • admin

    The issue is because of Java version mismatch.

    Java 8 = 52
    Java 7 = 51
    Java 6 = 50
    ...
    

    These are the assigned major numbers. The error regarding the unsupported major.minor version is because during compile time you are using a higher JDK and a lower JDK during runtime.

    Thus, the 'major.minor version 52.0' error is because the jar was compiled in jdk 1.8, but you are trying to run it using a jdk 1.7 environment. The reported number is the required number, not the number you are using.
    source:http://stackoverflow.com/questions/22489398/unsupported-major-minor-version-52-0



  • you are right
    java version was not good
    thanks