GPU not found when trying to plot with gpuPlotGenerator

  • Hello! I'm trying to use the gpuPlotGenerator to generate plots. But it doesn't list my gpu which is a RX460. Heres what it looks like: alt text

    If i pick the "Baffin" device i get a device with 1gb of memory and inferior speed, around 8k nounces per minute.

    I just can't figure this one out. Appriciate any help i can get.

  • admin

    @Casse Guess you have installed AMD GPU drivers?! Is that 'Baffin' something you know/have or do you think it is wrongly detected and should be the RX460 ?!
    The setup you run there is generating a devices.txt ... the setup is optional, you can also edit/modify devices.txt manual ... like described here: But i would start with re/install AMD drivers.

  • Hi. Baffin is the graphics processor in the RX-460. I have an RX-480 and it shows up as Ellesmere. So that IS your card. For what it's worth, I also only have about 1GB show up. I plot in direct mode under Windows 10. During the first part of the plot I see speeds over 50000. Then the display stops updating till the file is written. On the second pass where it optimizes my speeds are much slower...I'm at 98% on a drive now and I'm seeing 7843 nonces/minute. I'm pretty sure I have the right AMD drives, but it wouldn't hurt to check.

  • @luxe

    Ok problem solved. Just like Evo said Baffin is the GPUs name. The fault was within the settings in the device file. I ran 30k nounces per minute after some tweaking.

  • @Casse, good to hear that your getting faster plotting. In my case my monitor is also attached to the same graphics card, and if the the devices.txt values are too aggressive I suspect that there is some resource overlap which kills performance.

  • @Evo

    I have a new issue. After plotting the whole night at 30k nounces/m i suddenly have 60 nounces/m while still using all my ram. Im not writing anything to my disks. Here is what it looks like:
    alt text

    Is this the optimization or whats going on? Not ready to cancel after a whole nights progress

  • admin

    @Casse the 'direct' mode means you create optimized plotfile directly ... on SMR drives this can be very slow. (Always much slower than buffer)
    So i suggest, plot to PMR drive in such a case and copy / optimize over to SMR after finished or use 'buffer' mode.
    I have no numbers but i think that xplotter (cpu) is faster creating optimized plotfiles directly ...
    The 'buffer' mode writes sequential while 'direct' mode does a lot of read/write operations.

Log in to reply

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.