Problems with plotting Google Drives



  • I was trying to plot a total of 9 Google Drives, so I install NetDrive2 and had my GD at my PC...
    Next, i try to plot with the plotter of the Wallet (only had been doing this way). So I was testing just do for 5GB and it worked.
    I start calculating and thinked this could work, so i looked for manual plotting and looks like i have two solutions. Use the wplotgenerator (CPU) or the GPU plotgenerator. The second looks more interesting so i'd try it... Actually i try it a lot, withe the help of @JohnathanMoura Thanks! I think this should be right:

    gpuPlotGenerator generate direct y:/plots/4162537466170472951_0_55296_2048
    

    And didn't worked... only i got is this
    [ERROR] Unable to open plots file

    I was trying to generate a plot of 15GB on drive Y and use about 512mb of RAM so i can put 2 drives plotting with GPU and maybe another 3 using CPU, since i have a lot of Google Drives to plot...
    Since I don't understand a lot of Graphics downloaded the GPU-Z and this tells me that my graphycs card is ** NVIDIA GeForce 820M (1GB DDR3 - 14.4 Gbit/s bandwidth)** and that i have a ** Intel HD Graphics Family (doesn't know how much RAM have, only it's DDR3 - 12.8Gbit/s bandwidth)** too. The two boards are OpenCL ready...

    So @JohnathanMoura and I thinked it was my board that somehow didn't worked. Someone could help with this please?

    Since I cannot worked with GPU I'd try the wplotgenerator to create plots of 2 Google Drives at same time, last night, supposdly 13GB each. I woke up and looks like it's done, but afterall is not. I go to my explorer and the drives are empty...

    This is what i used:

    wplotgenerator 4162537466170472951 0 55000 2048 2 t:/burst/plots
    

    Yesterday the command worked, but when i woke up the plotting was not done. In the Explorer that was nothing in this drive...

    I also had tryed with 1 thread so i can put at least 3 plotting at same time with:

    wplotgenerator 4162537466170472951 0 55000 2048 1 t:/burst/plots
    

    What i got it was always:

    Adjusting total nonces to 55296 to match stagger size
    Creating plots for nonces 0 to 55296 (13 GB) using 512 MB memory and 2 threads - using AVX2 codepath
    Setting priority class 'below normal'.
    Opened existing file with a size of 14495514624 bytes.
    File is already finished. Delete the existing file to start over.
    

    This error today happens with all the codes that i use with wplotgenerator... I can Plot with the wallet only. This tooks too much... I can put only 1 thread by plot but i can't choose the amout of RAM to be used so i can set up 3 plots at the same time.

    Someone?
    Thanks in advance



  • Normally i mine with the CPU but since the problems with the GPU, I'd try to mine with GPU and that works good... what doesn't work good is plotting.

    P.S.: Sorry for the will?!


  • admin

    @gpedro said:

    I also had tryed with 1 thread so i can put at least 3 plotting at same time with:

    wplotgenerator 4162537466170472951 0 55000 2048 1 t:/burst/plots
    

    please watch the video about plotting here:

    e.g. the size (55000) must be a multiple staggersize (2048) but 55000/2048 = 26,85546875
    so that can not work out well.

    File is already finished. Delete the existing file to start over.
    

    also you have to change the startnonce (0) to last startnonce+size, or you will have overlaping plots, in this case the file already exists.



  • @luxe @JohnathanMoura Thanks... i'm plotting 3 drives of 15GB with wplotgenerator at the same time.

    wplotgenerator 4162537466170472951 110592 55296 2048 1 w:/burst/plots

    Regardeless to the GPU anyone? I have 1TB External USB Drive in here to format too and with wplotgenerator will take forever to plot this up...



  • @ponyboy had trouble plotting directly to Amazon Cloud Drive and I had trouble plotting directly to OneDrive. For both of us it was easier to plot the files locally, and then upload them using the cloud service's upload tool. He was able to mine them afterwards, but I was not (we're using two different clouds).

    Based on that I'm wondering if you are plotting directly to your Google Drive, or if you are uploading them afterwards? Because if you are plotting them directly into the cloud it may cause some of the problems you are experiencing.



  • @Propagandalf I installed NetDrive2 and put in there 9 Google Drive accounts and i'm plotting 2 each time for now with wplotgenerator... Afterall what i was doing wrong was run wplotgenerator.exe from C. to plot Z:

    Since i put the wplotgenerator.exe in each drive i was able to plot them. Take an extra ~2 min each drive and instead of 15Gb, plotted i only can do 13GB each.



  • @Propagandalf yesterday i was able to plot all the Google Drives but today is nothing inside that Drives plotted with the wplotgenerator...
    Also with wplotgenerator I'd made 2 plots of 1336832 nonces on a External-USB2.0 1TB HDD and they appear on the HDD but when i'm going start to mine all the plots that i've done with wplotgenerator don't appear on the miner.
    I 've to do anything more before mining wplotgenerator plotted HDD's?



  • @gpedro edit the path on the miner folder or open the wallet and see if the hdd is on the found plots, if it is choose the pool and start mining.

    0_1468006271112_upload-5b91c524-a495-49dc-a65c-7a37ae2c7668



  • @JohnathanMoura they weren't. That's was the problem... But anyway i've fixed it.
    Seems the problem was with my External HDD temperature... I shutdown the PC and unplugged the external HDD, had go dinner and when i came back, like 15 minutes later I log in into my pc and C and D drive usage was at 100% and my pc was very slow, so i begun a plot again and kill the process 'wplotgenerator.exe' since i couldn't kill the process 'System and compressed memory' (same process that handle the writing on the plotter) and the 100% came down to 5%. After that i plugged the HDD again and try to mine and the plots of the External HDD was there xDD
    now i'm mining with my brand new 907GB and at the same time i'm plotting another 257GB...

    With the Google Drives, i think the problem was that I was plotting directing to the NetDrive2 Drive created on my PC, so i will try to replot them locally and then upload to the drive, later today, as @Propagandalf and @crutsy as advise me... When it's done, i will post the results here...



  • I didn't know you could do this. My school has unlimited google drive account space! looks like I'll be taking advantage of that this year 🙂



  • @LeG3NdArYPhiL you could but the reading speeds are low... if you have google drive unlimited space you could try upload a 60Gb plot and for someone like me with real 8/9 Mb/s upload speed, will take ~20h to upload one file through the browser, and if you try transfer with NetDrive they blocks files bigger that 10Gb so you could only do it for the browser. but if you could do it you can add 60Gb to your plot every day for FREE (7days60Gb=420Gb/week4=1680Gb/month) and that's fucking amazing.



  • @gpedro

    Hey man I found it to slow to try to even think of plotting up to google drive and MSloth OneDrive. The time it was taking was heating the rest of my system up.
    What I did:Try plotting Local and copy the plot file up.
    If you have unlimited Google has a limit on the size of the file (To Copy) I believe its 250 Gigs. So you gotta break it down and just throw up a shit ton of 250 Gig plots Make sure you map the drive and reconnect at logon that helps keep it alive. also set it to sink every six hours or so with just one small txt file that will keep it alive. When mining. Google was to much of a pain in the ass, One Drive was more forgiving more space initially W/WinDoz 10. I just use bare minimum. I am sure just a matter of time before GUggle and MSloth figure it out. Good luck Bud hope you get it working.

    Kind Regards,

    ~LostBoy



  • Your internet speed will directly correlate with how much you are able to mine on a google cloud. It can be done and google is the best in my testing. I a few hundred GB running flawlessly for over a month.



  • @LostBoy Plot directly trough NetDrive doesn't work for me too... If i had an infinite cloud storage would be so nice xD
    @crutsy what i will try to do is to put like 3 drives reading in parallel with my local plots and the others (in a group of 5 each or so) after the miner reads the local ones, like that you could be reading plots until the end of the block and you could even hit a deadline of 1 minute on your last Google Drive cloud. As soon i've finished my uploads of the 13 plots to the drives i will start testing witch are my best speeds with that drives (i've been doing this in the last days and only left 2 uploads xP)



  • @gpedro It is my thinking that you want it to happen right away. On fast blocks you would miss out and I would think it would increase overall read time. However I am always open to testing! Looking forward to your results.

    I have been busy but plan on adding to my google drive to test the limits.



  • @crutsy Yes that it... as soon as i do my tests i will post the results... If i can do this the most important thing don't is the space anymore is the space i can read in a block time xD



  • @crutsy
    Good to know it works, I find OneDrive working better than Google for me. Would like to get both, every sector counts in my book:)

    ~Lostboy



  • @LostBoy the limit here is only the bottleneck of your network bandwitch you should see what is faster for you and put that at the maximum limit of what you can. That's how we play in my book xP



  • @crutsy @LostBoy I've discover that the upload is like 1 h faster if you upload in a folder instead of being the file. I guess Google don't limits the folder upload but limits the file upload....



  • @gpedro That is very interesting I will have to try that. Are you sure nothing else changed in that time? My upload can take an hour longer if my lady is watching netflix all night. haha she looses high def when burst is mining a block tho