GPU plotting stuck



  • I been trying to plot a 4TB of my 8TB drive.
    Its starting every time but stuck at 0.19% and nothing happens even after 12 hours.
    I tried multiple time and it stuck at same percentage.
    Its been two days i am trying to plot a TB but no success.
    NO CPU or GPU is running. Please help me for my first GPU plotting.
    I am very new to this GPU and can i use my intel GPU in my laptop.

    alt textalt textalt textalt text



  • it's direct mode, in the task manager, you can see your drive is working to create the file, and then it will start plotting 🙂



  • @HiDevin thanks for the reply. I tried the buffer mode yesterday and the same result. i see GPU load as 1% and doubted its stopped. The percentage is not changed even after around 12 hours.



  • @natsaba in buffer mode, sometimes it runs out of mem and u have to replot.



  • @HiDevin I have 12 GB RAM in CPU and what should be my stagger size, i will recalculate the plot details based on that.



  • " When you plot in direct mode it creates the empty file, then fills it in, while it's creating it there will appear to be zero progress, but if you look at disk activity in Resource Monitor, you'll see it's writing to disk. Once the empty file is created, it'll be filled in, and thats when you'll see progress. Depending on the size of the plot you're doing it can sit at the initial progress screen for many hours - but as long as you have disk activity, it's working. "

    " 4401562696129194441 - replace with your numeric account ID
    106430464 - nonce to start at. If this is your first plot use 0
    7618560 - number of nonces to plot, must be a multiple of the stagger - the next field
    16384 - stagger. Each 1 = 256 KB of memory, so divide by 4 to get amount of memory to use. In this case it's 4GB (4096 MB) "

    all from @haitch XD



  • @HiDevin I did change the stagger and size of the plot to know its working.
    Now i have 500GB and stagger as 16384 in direct mode.

    Though the progress stuck at 0.75%, i see some activity in taskmanager for memory and disk.
    So the current ETA which is stuck at same for 30 mins is 3h 16m 17s, your saying it would change once the plot is created and started filling right?
    alt text



  • ETA is inaccurate, only direct mode takes longer because it is creating a optimized file



  • After 4 hours to plot 500GB with GPU/direct. Nothing changing, still its stuck with 0.75%.
    Any one could help me to identify what am doing wrong here.
    alt text

    The disk and RAM consumption for this 500 GB plotting.
    alt text



  • After leaving it for around 5 hours. the plot is zero byte and the plotter stayed with 0.75%.



  • @HiDevin any idea why it stuck there.



  • @natsaba the plot sometimes glitches out so right click it and hit properites to see how big the file is, or check task manager if its still writing to drive.



  • Why are you making it so complicated and frustrating ?

    For test runs, please stick to buffer mode, use a small target size.
    THEN you can see immediately if data is being generated and written to disk.
    When you have found a working parameter set you may switch to direct mode.
    The parameters you are looking for are

    • fields 3,4,5 of the devices.txt
    • optimal stagger value (or, not too intrusive RAM usage)

    Show your devices.txt, please.



  • @vaxman Thanks. i will try to plot smaller once today.
    here is my devices.txt setting.

    0 0 1024 128 8192



  • @natsaba said in GPU plotting stuck:

    @vaxman Thanks. i will try to plot smaller once today.
    here is my devices.txt setting.

    0 0 1024 128 8192

    There are "ROP 8/16" in GPUZ, you need to decrease the 4th parameter.
    Try 64,32,16,8 to find the "sweet" spot with maximum output.

    If that does not produce a, say, 2 GB file succesfully, decrease the 5th parameter and try again for the 4th.



  • @vaxman I have tried to reduce the 4th and 5th parameters. I got it work for 20GB test plot at 4800N/minute. I got better speed with xplotter around 5000 N/Minute. So for now using xplotter to plot 1TB plot. Thanks for y
    ou help.



  • I updated the GPU plot generator (v4.1.1). It now comes with file pre-allocation when launched with admin rights, which greatly speed things up in terms of IO operations for direct writing strategy.



  • @cryo thanks, i will try and share the results here



  • @cryo i couldn't find any read me or run.bat in gpuPlotGenerator-bin-win-x64-4.1.1.7z. How should i run and where i have to specify the plots and configs.


  • admin