Mjminer plotter fork for Optimized Plots on macOS (CPU, AVX2, SSE4)

  • Recently optimised mjminer plotter to produce fully optimised plots directly. Use same arguments as usual but prepend with sudo, it just produces fully optimised plot files:

    It requires root access because of fast file allocation without zeroing its content – which is potentially not safe, because app will be able to access data of deleted files. But in case of plotter it is not a problem – files gets allocated, then is fully rewritten. You can read all changes in this pull request:

    I wanna this PR to be merged into original repository. Do anyone have contact of @r-majere?

    Described process of plotting/mining on macOS in this article:

    If you tried my fork and it works under your Linux, please write a comment with you Linux distribution and version.

  • admin

    Hi @k06a ,

    damn you are good.

    If @r-majere is out of town for longer we can replace the links in the tutorials in favor of your fork.

    What I don't get from the beginning of the mjminer:

    ...then open file shabal64-darwin.s in any text editor and replace the single quote with double quote on line 30 as bellow
     64      'ptr' field (8 bytes)
     64      "ptr" field (8 bytes)

    Why can't this be fixed?

  • @daWallet maybe this needed to be fixed only on macOS, this repo still supports linux. I am not sure about this lines.

  • @k06a Any plans / know of anyone who has successfully ported the Mac OS one to an actual BSD os? like FreeBSD?

  • Hello!

    Great work! Its working on Linux for me. For some reason it does sometimes fail halfway through quoting "error creating thread", but the actual program says that it can be restored from x step, how do you restore the plotting?


  • I've tried this plotter on my Mac Pro 2009.

    The plotting of 1.9Tb took about 45seconds!! But plot is not valid, deadlines are to far of pool.

    Does anyone has the same problem? Is there any solution?

  • @enotbert Target deadline of pool in your miner config file?