Need help in configuring JMiner for GPU mining



  • Hi all,

    Again, I need help and I hope you can help with your expertise.

    I have a running setup wit blago's miner and now I am wanting to take the load from my CPU to my GPU.

    My setup:
    AMD Phenom II X4 955
    ATI Radeon HD 4550 (8.970.100.7000)

    Right now my 8TB disks are taking at least 100sec (~20MB/sec) to be scanned. I guess that's not a good result and I am hoping that JMiner can do it faster with my GPU.

    I downloaded JMiner 0.4.10.

    Here is my current config:

    plotPaths=U:/Burst/plots,H:/Burst/plots,F:/Burst/plots,E:/Burst/plots,I:/Burst/plots,J:/Burst/plots,K:/Burst/plots,
    poolMining=true
    numericAccountId=844XXXXXX
    poolServer=http://pool.burstmining.club:8124
    walletServer=https://wallet.burst-team.us
    targetDeadline=604800
    platformId=0
    deviceId=0
    

    I have to say that this config works but seems to run with the CPU and is also very slow.

    I have no plan what platformId and deviceId I need to configure.
    I tried some combinations and also tried to find these values in win computer management and cpu-z or speccy. No chance...

    I read something about OpenCL. Do I have to install this or is it already part of the Catalyst driver?
    How can I find out my platformId and deviceId?

    Thanks!


  • admin

    @fpdragon Download gpuplotgenerator and run it as "gpuplotgenerator setup", select option 0, it'll list your platform/device IDs. Find the one for your GPU and use that in the jMiner conf.



  • @haitch
    Thanks!

    I got the following:

    [0] AMD Accelerated Parallel Processing (OpenCL 2.0 AMD-APP (1912.5))
        [0] AMD Phenom(tm) II X4 955 Processor (OpenCL 1.2 AMD-APP (1912.5))
    

    So it seems that my graphic card wasn't detected?


  • admin

    @fpdragon Apparently not. What GPU? Up to date GPU Driver ?



  • @haitch
    ATI Radeon HD 4550
    (Driver: 8.970.100.7000)
    pretty old, I know...
    But the cpu is also old so I was thinking that the GPU is maybe faster. xD

    And I don't use it anyway so CPU power is much more important for me.

    By the way... It's a Windows Server 2016 machine


  • admin

    @fpdragon said in Need help in configuring JMiner for GPU mining:

    HD 4550

    For abn old card, you probably need to install the SDK to get openCL support.

    http://developer.amd.com/tools/hc/AMDAPPSDK/Pages/default.aspx



  • @haitch
    I installed
    AMD-APP-SDK-v2.9-1.599.381-GA-Full-windows-64.exe without any error.
    The newer v3.0 seems to be not compatible with Windows Server

    Then reboot...

    GPU-Z says still no OpenCL support.

    But here
    https://www.techpowerup.com/gpudb/232/radeon-hd-4550
    it says that the card should support OpenCL 1.0 .

    Maybe a driver problem?


  • admin

    @fpdragon AMD GPU's and Windows Server do not play nicely. AMD basically will not provide drivers compatible with Windows Server. Try Windows 7/8/10



  • Till now I had no problems in installing drivers on Windows Server 2016.

    I tried some drivers from the ATI/AMD website but GPU-Z always says that it has no OpenCL support.
    But from the information from the internet it seems that the HW should have OpenCL support.

    Maybe I should search for a specific driver version where it is clear that it supports OpenCL. But it's hard to find... -_-