Blago Miner Config file

  • admin

    @khnkdn I've never seen the chosen_pool or chosen_port file, and passphrases.txt is only required for solo mining.

    Use the example, and configure miner.conf for your setup.

  • @khnkdn ,

    for solo mining you have to fill in your passphrase. The other ones I deleted from my folders.

  • @haitch said in Blago Miner Config file:

    @khnkdn I've never seen the chosen_pool or chosen_port file, and passphrases.txt is only required for solo mining.

    Use the example, and configure miner.conf for your setup.

    Actually the chosen pool and chosen port files are for the AIO IIRC, when you pick a pool from the start mining tab.

  • @rds @haitch this is my config file, but I get an error when I start up the miner.
    "Mode" : "pool",
    "Server" : "",
    "Port": 8880,

    "UpdaterAddr" : "",
    "UpdaterPort": "8880",

    "InfoAddr" : "localhost",
    "InfoPort": "8125",

    "EnableProxy": false,
    "ProxyPort": 8126,
    "CacheSize" : 100000,

    "Debug": true,
    "UseHDDWakeUp": true,

    "TargetDeadline": 80000000,

    "SendInterval": 100,
    "UpdateInterval": 950,

    "UseLog" : true,
    "ShowWinner" : false,
    "UseBoost" : false,

    "WinSizeX": 76,
    "WinSizeY": 60
    The JSON Validator says:
    Error: Parse error on line 14:
    ...": 8126, "Paths": ["e:\burst\plots", "f
    Expecting 'STRING', 'NUMBER', 'NULL', 'TRUE', 'FALSE', '{', '[', ']', got 'undefined'

    I have tried retyping these two lines but no change. any ideas?

  • admin

    @khnkdn the \ in the paths needs to be two \ - \\

  • @haitch that worked. I double clicked on the miner program and got this:
    BURST miner, v1.170820
    Programming: dcct (Linux) & Blago (Windows)
    CPU support: AES SSE SSE2 SSE3 SSE4.2 AVX [recomend use AVX]
    GenuineIntel Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz [4 cores]
    RAM: 8192 Mb
    Pool address (ip
    Updater address (ip
    Using plots:
    e:\burst\plots files: 4 size: 7450 Gb
    f:\burst\plots files: 4 size: 7450 Gb
    g:\burst\plots files: 4 size: 7450 Gb
    TOTAL: 22350 Gb

    23:33:15 New block 402861, baseTarget 265979, netDiff 68897 Tb
    23:33:26 [ 4360178474035346982] found DL: 714839
    23:33:26 [ 4360178474035346982] sent DL: 714839 8d 06:33:59
    [ERROR 1004] Your Burst account's reward recipient (7Z2V-J9CF-NCW9-HWFRY) does not match pool's account (9UXJ-H8LW-5Q7X-
    You need change reward assignment and wait 4 blocks (~16 minutes)
    23:34:01 Thread "f:\burst\plots" @ 46.0 sec (40.5 MB/s) CPU 55.89%
    23:34:01 Thread "g:\burst\plots" @ 46.1 sec (40.4 MB/s) CPU 55.52%
    23:34:04 Thread "e:\burst\plots" @ 48.9 sec (38.1 MB/s) CPU 52.84%
    it still thinks the reward recipient is wrong.

  • admin

    @khnkdn You've got the reward recipient set to the old address for the pool - that one was compromised and had to be changed. Set the RR to BURST- 9UXJ-H8LW-5Q7X-A7WC2

  • @haitch I have tried in the AIO but it gives me an error when I overwrite the RR with the correct address. I was thinking if I run the miner outside of the AIO that I would not need to do that or that the config file would take care of all of that. This is confusing to me. I really would like to mine, but getting this all straighten out has been frustrating. Can i only change the RR inside the AIO?

  • @haitch when I submit the change for the reward recipient I get the error: {"errorDescription":"Incorrect "recipient"","errorCode":4}

  • admin

    @khnkdn To change the RR goto: - set the reward assignment to BURST-9UXJ-H8LW-5Q7X-A7WC2 then manually configure and run Blago's miner.

  • @haitch It gave me the same error on that site also.

  • admin

    @khnkdn I typoed the original link, then edited it - try again, copy/paste the address from the post in the recipient field, making sure you don't have any spaces or newlines

  • @haitch now I wait 15 minutes before firing off the miner?

  • admin

    @khnkdn it's 4 blocks, on average 4 minutes per block, but we had a 42+ minute block earlier today

  • @haitch Thanks for your help. The miner seems to be working. Since this is your pool, is it possible to tell if I am actually doing any work that will earn burst?

  • @haitch I did not know that "chunkPartNonces" was also a possible property for Blago's miner. I wonder also what is "UseBoost" for?

  • Can anyone explain what I am seeing as the output of the miner and should I be concerned about the HDD, Wake Up! message?
    :39:11 New block 403166, baseTarget 151975, netDiff 120580 Tb
    19:39:26 [ 4360178474035346982] found DL: 434604
    19:39:26 [ 4360178474035346982] sent DL: 434604 5d 00:43:24
    19:39:27 [ 4360178474035346982] confirmed DL: 434604 5d 00:43:24
    19:39:33 [ 4360178474035346982] found DL: 75261
    19:39:33 [ 4360178474035346982] sent DL: 75261 0d 20:54:21
    19:39:34 [ 4360178474035346982] sent DL: 75261 0d 20:54:21
    19:39:36 [ 4360178474035346982] confirmed DL: 75261 0d 20:54:21
    19:39:53 Thread "e:\burst\plots" @ 41.6 sec (44.8 MB/s) CPU 62.56%
    19:39:55 Thread "g:\burst\plots" @ 43.6 sec (42.8 MB/s) CPU 60.01%
    19:39:55 Thread "f:\burst\plots" @ 43.6 sec (42.8 MB/s) CPU 59.93%
    19:42:55 HDD, WAKE UP !
    19:45:55 HDD, WAKE UP !

    19:48:38 New block 403167, baseTarget 162350, netDiff 112874 Tb
    19:48:59 [ 4360178474035346982] found DL: 11742
    19:48:59 [ 4360178474035346982] sent DL: 11742 0d 03:15:42
    19:49:00 [ 4360178474035346982] confirmed DL: 11742 0d 03:15:42
    19:49:21 Thread "g:\burst\plots" @ 42.8 sec (43.6 MB/s) CPU 60.07%
    19:49:21 Thread "e:\burst\plots" @ 42.9 sec (43.4 MB/s) CPU 61.68%
    19:49:23 Thread "f:\burst\plots" @ 44.3 sec (42.1 MB/s) CPU 60.29%
    19:52:23 HDD, WAKE UP !

  • @khnkdn what you see are deadlines being found by the miner, sent to the pool and then confirmed. Also the time it takes the miner to read each drive and effective CPU power.

    The HDD wake up is a feature of Blago miner so that your drives don't go to sleep (idle) in case there is a long block. I am not sure but I think this is set to 4 min.

Log in to reply

Once You Know, You Newegg

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.