How do I restart a plot using Blago's CPU Xplotter after a crash



  • Here is my command line in the starting batch file:
    XPlotter_avx.exe -id 125495405788627XXXXX -sn 3440627 -n -t 8 -path D:\plots -mem 2G

    And this is the file it created
    12549540578862786726_3440627_5845680_5845680

    2 questions.

    1. How do i restart the plot?
    2. How do i know what Starting Nonce and Quantity of Nonces to do now?

    Thanks for any help.



  • To continue plotting, you need to include the flag "-n 5845680" in your command, because that's the number of nonces created the first time you ran it (it is included in the file name for future reference).



  • @tinycoins
    5845680 is the number of nonces I want to create or that plus one is the Starting Nonce of the next iteration? I thought 5845680 was the number of the final nonce created before the crash so:
    5845680 final nonce
    -3440627 starting nonce
    =2405053 being the number of nonces created in the first attempt.

    I am very confused by this HDD mining.

    So i dont have to do anything to continue the previous attempt, i am just starting a new one where the old one left off. Is that correct? So i will have two plot files not one?
    I appreciate your reply @tinycoins



  • You didn't specify a number of nonces the first time, so xplotter just filled the space. It determined the number of nonces to do that.

    In your filename,

    12549540578862786726_3440627_5845680_5845680

    3440627 is the starting nonce and the file is eventually going to contain 5845680 when complete.

    I think it's shown twice in the filename to represent the fact that it will be optimized.

    Try running the following:

    XPlotter_avx.exe -id 125495405788627XXXXX -sn 3440627 -n 5845680 -t 8 -path D:\plots -mem 2G

    And it should pick up where it left off



  • And when that's complete, your next starting (-sn) value will need to be 3440627+5845680.

    If you don't specify the number of nonces or set -n to be zero, xplotter uses all available space on the selected drive.



  • It has been awhile since I plotted a drive, but I think if you just rerun the batch file again(with your starting and number of nonces and location) it picks up where it left off. Might be wrong, but I remember having to restart multiple times and it always started where it left off.



  • Correct, unless you didn't specify the number of nonces the first time - in which case you have to alter the '-n' parameter to match the file it created. Otherwise it will keep creating zero-length files because it thinks you want to start filling the remaining space again.



  • @tinycoins Hi. I'm getting this message about requiring administrative privs. I changed the properties on the to Xplotter.exe programs to Run as Administrator. But, this first start up was from Dynamic Plotting on the Burst Wallet Menu.

    I'm not sure what the parameters for the restart should be. Can you gleen the required parameters from this log of activity displayed by the plotting cmd window?:

    XPlotter v1.0 for BURST
    programmers: Blago, Cerr Janror, DCCT

    Checking directory...
    Drive k:\ info:
    Name: LIBRARY
    File system: NTFS
    Serial Number: 136329174
    FILE_SUPPORTS_SPARSE_FILES: yes
    Bytes per Sector: 4096
    Sectors per Cluster: 1
    The token does not have the specified privilege.
    For faster writing you should restart plotter with Administrative rights.
    Creating file: k:\mining\burst\0_532480_40960_40960
    ID: 0
    Start_nonce: 532480
    Nonces: 40960
    Nonces per thread: 2048
    Uses 1024 Mb of 19295 Mb free RAM
    Allocating memory for nonces... OK
    [0%] Generating nonces from 532480 to 534528
    [5%] Generating nonces from 534528 to 536576
    [10%] Generating nonces from 536576 to 538624
    [15%] Generating nonces from 538624 to 540672
    [20%] Generating nonces from 540672 to 542720
    [25%] Generating nonces from 542720 to 544768
    [30%] Generating nonces from 544768 to 546816
    [35%] Generating nonces from 546816 to 548864
    [40%] Generating nonces from 548864 to 550912
    [45%] Generating nonces from 550912 to 552960
    [50%] Generating nonces from 552960 to 555008
    [55%] Generating nonces from 555008 to 557056
    [60%] Generating nonces from 557056 to 559104
    [65%] Generating nonces from 559104 to 561152
    [70%] Generating nonces from 561152 to 563200
    [75%] Generating nonces from 563200 to 565248
    [80%] Generating nonces from 565248 to 567296
    [85%] Generating nonces from 567296 to 569344
    CPU: 36808 nonces done, (864 nonces/min)

    If you can, thanks, so much.

    Gary


  • admin

    @addisonbrooks16 Your ID is incorrect, you're plotting for account 0.

    The restart command line should be:

    xplotter_avx -id <your_id> -sn 0 -n 40960 -t <number of threads> -path k:\mining\burst -mem <x>GB

    adjust the parameters as required.

    Right click on the batch file and select run as administrator