Qbundle 1.8 fails to start on both my machines I upgraded



  • So as soon as I downloaded Qbundle 1.8 from 1.7, both my wallets stopped working. Haven't wanted to risk losing my plotting I got going on right now for down time to redo everything. This also happened to me when we went from 1.5 to 1.6 and so delete everyting on one machine and strated over with the new Version and it all worked fine. I tried with my othjer machine for a few days but gave up eventually and restarted. thanks! Jan 10, 2018 6:05:46 PM nxt.Nxt getBooleanProperty INFO: nxt.disableGenerateBlocksThread not defined, assuming false [INFO] 2018-01-10 18:05:47 LoggerConfigurator - logging enabled [INFO] 2018-01-10 18:05:47 nxt.Nxt - nxt.maxRollback = "1440" [INFO] 2018-01-10 18:05:47 nxt.Nxt - nxt.isTestnet = "false" [INFO] 2018-01-10 18:05:47 nxt.Nxt - nxt.isOffline = "false" [INFO] 2018-01-10 18:05:47 nxt.Nxt - nxt.dbUrl = "jdbc:h2:./burst_db/burst;DB_CLOSE_ON_EXIT=False" [INFO] 2018-01-10 18:05:47 nxt.Nxt - burst.enableSqlMetrics = "false" [INFO] 2018-01-10 18:05:47 nxt.Nxt - nxt.dbUrl = "jdbc:h2:./burst_db/burst;DB_CLOSE_ON_EXIT=False" [INFO] 2018-01-10 18:05:47 nxt.Nxt - nxt.dbUsername = "sa" [INFO] 2018-01-10 18:05:47 nxt.Nxt - nxt.dbPassword = "sa" [INFO] 2018-01-10 18:05:47 nxt.Nxt - nxt.dbMaximumPoolSize = "10" [INFO] 2018-01-10 18:05:47 com.zaxxer.hikari.HikariDataSource - HikariPool-1 - Starting... [SEVERE] 2018-01-10 18:06:00 com.zaxxer.hikari.pool.HikariPool - HikariPool-1 - Exception during pool initialization. org.h2.jdbc.JdbcSQLException: General error: "java.lang.NullPointerException" [50000-196] at org.h2.message.DbException.getJdbcSQLException(DbException.java:345) at org.h2.message.DbException.get(DbException.java:168) at org.h2.message.DbException.convert(DbException.java:295) at org.h2.engine.Database.openDatabase(Database.java:307) at org.h2.engine.Database.<init>(Database.java:270) at org.h2.engine.Engine.openSession(Engine.java:64) at org.h2.engine.Engine.openSession(Engine.java:176) at org.h2.engine.Engine.createSessionAndValidate(Engine.java:154) at org.h2.engine.Engine.createSession(Engine.java:137) at org.h2.engine.Engine.createSession(Engine.java:27) at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:354) at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:116) at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:100) at org.h2.Driver.connect(Driver.java:69) at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:117) at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:123) at com.zaxxer.hikari.pool.PoolBase.newConnection(PoolBase.java:375) at com.zaxxer.hikari.pool.PoolBase.newPoolEntry(PoolBase.java:204) at com.zaxxer.hikari.pool.HikariPool.createPoolEntry(HikariPool.java:445) at com.zaxxer.hikari.pool.HikariPool.checkFailFast(HikariPool.java:516) at com.zaxxer.hikari.pool.HikariPool.<init>(HikariPool.java:116) at com.zaxxer.hikari.HikariDataSource.<init>(HikariDataSource.java:72) at nxt.db.sql.Db.<clinit>(Db.java:130) at nxt.Nxt$Init.<clinit>(Nxt.java:245) at nxt.Nxt.init(Nxt.java:202) at nxt.Nxt.main(Nxt.java:193) Caused by: java.lang.NullPointerException at org.h2.mvstore.db.ValueDataType.compare(ValueDataType.java:104) at org.h2.mvstore.MVMap.compare(MVMap.java:713) at org.h2.mvstore.Page.binarySearch(Page.java:334) at org.h2.mvstore.MVMap.binarySearch(MVMap.java:466) at org.h2.mvstore.MVMap.get(MVMap.java:455) at org.h2.mvstore.db.TransactionStore.commit(TransactionStore.java:349) at org.h2.mvstore.db.TransactionStore$Transaction.commit(TransactionStore.java:783) at org.h2.mvstore.db.MVTableEngine$Store.initTransactions(MVTableEngine.java:254) at org.h2.engine.Database.open(Database.java:767) at org.h2.engine.Database.openDatabase(Database.java:276) ... 22 more Exception in thread "main" java.lang.ExceptionInInitializerError at nxt.Nxt$Init.<clinit>(Nxt.java:245) at nxt.Nxt.init(Nxt.java:202) at nxt.Nxt.main(Nxt.java:193) Caused by: java.lang.RuntimeException: com.zaxxer.hikari.pool.HikariPool$PoolInitializationException: Failed to initialize pool: General error: "java.lang.NullPointerException" [50000-196]

    Thanks For looking!



  • @bitcon415

    Your post became very messy :)

    Anyway upgrade to v1.9. Start all over and use mariaDB from start. Let it sync from scratch and you will see you have a much better experience.



  • Ok, Do I need to stop my plotting?
    I don't want to loose good Plot time! :-)

    Sorry for the messy post! Kids and wife are always trying to keep me from mining. I just got 4 more 8TB drives to plot. Is my experience now limited to how fast my processor can read through a block during the 4min?

    Can I run one version of Blago to the same Pool with multiple accounts or is it best to just run Blago twice? I've been doing the later successfully.

    To mine Solo, what Size would be good enough to make it worth it in your opinion?

    Thank you so much!!!



    1. The plotter will not going to die because you update Qbundle unless you delete the directory Xplotter is in.
    2. A miner can only be set to one pool
    3. To solomine i think you should be looking at about 100-300TB with todays networksize.


  • @quibus Thanks Man! And my limitation of my system in the speed at which my processor can get though 4min of plotted drives? So I may nee multiple machine to hit those high TB?



  • Yes, As long as you can read and submit your DL when mining under 4 min your system is sufficient.



  • @quibus , respectfully, if you mining times are 4 minutes you're missing a lot of opportunity. 25% of all the blocks, on average finish in 2 minutes. If your plot had the magic DL but couldn't spit it out in time, you lose.



  • I understand your point @rds
    There might be a chance that just that time you are having a blocktime under 4 min another one has it to that has a faster rigg.
    This occurence might happen maybe once a year at most with above mentioned mining sizes.