Installing cg_obup Plotter for Linux error during installing, please help



  • Hi,

    im trying to install the optimized Plotter from PoC on Mintlinux 18.3

    after the command "make" i got this message and the installing ends:

    gcc -Wall -m64 -O3 -mtune=skylake -D_FILE_OFFSET_BITS=64 -c -o helper64.o helper.c
    helper.c:1:0: error: bad value (skylake) for -mtune= switch
    #include <string.h>

    so what to do ?

    can someone tell how to install the PoC Plotter ?



  • you seem to use an older version. Either update from master (git pull), or simply change the mtune=skylake into mtune=native in Makefile.



  • Hi,

    i just tried the actual cg_obup plotter on another pc with a newer CPU everything is working fine. I think my old CPU has no AVX 2 feature that's the key. So im just using the other PC.

    So im using Linux can you tell me how the converter for POC2 is working. My HDD are nearly 100 % full of nonces. Is this the way ?

    1. HDD a few nonces to RAM
    2. Converting from POC1 to POC2 in RAM
    3. Copying the POC2 nonces to HDD again.

    So can your planed converter converte 100 % filed HDD from POC1 to POC2 ?