Odroid XU4 Scavenger ARM7 - won't detect plot files - no plots found - SOLVED!

  • I've been mining on Windows 10 for about a month, and I've plotted up all my drives in Windows 10 (64 bit). I also mining on an old Linux machine simultaneously, with worse (slower) hardware. Suffice to say I like to think I'm getting some good experience at this across different platforms.

    Recently I got my hands on a Odroid and so far so good. Debian installed, sees my external drives, got an arm7 compatible version of Scavenger - all good I thought.

    However, I can't get it to recognise any of the plot files. I've had it working fine on Windows and Linux, but on this Arm7 device!? Nah, not yet.

    It sees the folders (so I know my config.yaml is okay). I'm providing full mouted paths such as:

    • '/media/path/to/my-plotfiles/SEAGATE_whatever1'
    • '/media/path/to/my-plotfiles/SEAGATE_whatever2'

    My plots are large. Single 5.45TB files...could this be the problem? That's what I thought....but can't be, because Scaveneger tells me that no plots files exist for its own test-data plots, and they're tiny.

    Does anyone have any Odroid expereince here?

    Why is Scavenger reporting that no plot files exist, even though it can see the folders?

    If I take the same drives with more or less the same configuration onto Windows (the paths are slightly different), it works OOTB.

    Any help would be greatly appreciated.


  • Just as an update to this, it turns out that the arm7 devices don't support direct_io.

    In the config.yaml file the following line needs to be set to false (NOT true) as per the default.

    hdd_use_direct_io: false              # default true

    As soon as I did this, with some guidance from the dev, it all worked flawlessly and has been running for a few days without hitch.